Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Язык программирования Паскаль. даны 2 числа а и b найти среднее арифметическое: (а+b)/2 ИСХОДНЫЕ ДАННЫЕ а=-6.00

10-11 класс

b=5.00

VIKUHA333 21 марта 2015 г., 10:18:06 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
мэри16
21 марта 2015 г., 10:59:46 (9 лет назад)

Program Task;
Var a, b: Real;
Begin
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
WriteLn('Среднее арифметическое: ', ((a + b) / 2):5:2);
ReadLn;
End.

Ответить

Другие вопросы из категории

Читайте также

помогите пожалуйста решить! ( паскаль )

Паша (p) купил 10 яблок, а Коля k яблок.


Известно, что Коля купил больше яблок, чем Паша.


На сколько (x) яблок Коля купил больше, чем Паша?




Исходные данные: k


Результат: x


Пример 1: для исходных данных: 15 должен быть результат: 5


Пример 2: для исходных данных:10 должен быть результат: 0

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)



Вы находитесь на странице вопроса "Язык программирования Паскаль. даны 2 числа а и b найти среднее арифметическое: (а+b)/2 ИСХОДНЫЕ ДАННЫЕ а=-6.00", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.