Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Ребят, помогите, пожалуйста, с задачей: ДАНО ЧЕТЫРЁХЗНАЧНОЕ ЧИСЛО,ВЫВЕСТИ НА ЭКРАН КУБЫ ЦИФР ЭТОГО ЧИСЛА(PASCAL). Заранее огромное спасибо.

10-11 класс

Hacune 30 марта 2015 г., 6:33:51 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tokko2014
30 марта 2015 г., 9:05:11 (9 лет назад)

var a, b, i :integer;   
     s :string;
begin   
   readln (a);   
   while a>0 do   
   begin
      b:=a mod 10;
      a:=a div 10;
      write (b*b*b, ' ');
   end;
end.

Ответить

Другие вопросы из категории

Число 100h

шестнадцатеричной
системы счисления в десятичной системе счисления равно:

а) 250; в) 255;

б) 251; г) 256.

Помогите пожалуйста.

Даны два числа - координаты точки в декартовой системе координат. Определить, к какой оси X млм Y она ближе.

Читайте также

Разделите точками цифры этого числа группами по три , начиная справа.

Программа получает на вход натуральное число , содержащее не более 100 цифр.
Программа должна вывести то же число , с точками между некоторыми цифрами этого числа.

Примеры входных и выходных данных

Ввод 1000 1.000
Вывод 12345678 12.345.678


Ребят, помогите пожалуйста объяснить задачи!!!

В целочисленной
последовательности есть нулевые элементы. Создать массив из номеров этих
элементов.



Program
Om1;

Uses
crt;

Var

a :array
[1..100] of real;

i,n,j :
integer;

x :
array [1..100] of real;

Begin

clrscr;

write('n=');readln(n);

for i:=1
to n do

readln(a[i]);

j:=1;

for i:=1
to n do

if
a[i]=0 then

begin

x[j]:=i;

j:=j+1

end;

for i:=1
to j-1 do

write(x[i],' ');

End.


Дана последовательность
целых чисел а1, а2….аn.
Выяснить какое число встречается раньше, положительное или отрицательное.


Program
num2;

Uses
crt;

VAr

a :array
[1..100] of real;

i,n :
integer;

Begin

clrscr;

write('n=');readln(n);

for i:=1 to n do

readln(a[i]);

for i:=1
to n do

begin

if
a[i]<>0 then

if
a[i]>0 then

begin

writeln('Положительное встречается раньше');

break

end else

begin

writeln('Отрицательное встречается раньше');

break

end;

end;

End.


Дана последовательность
действительных чисел а1, а2….аn. Выяснить будет ли она возрастающей.


Program
num4;

Uses
crt;

Var

a :
array [1..100] of real;

i, n, j
:integer;

Begin

clrscr;

write('n=');readln(n);

a[n+1]:=a[n]+1;

for i:=1
to n do

readln(a[i]);

j:=0;

i:=1;

while
i<n do

begin

if
a[i]<a[i+1] then

begin

j:=j+1;

i:=i+1

end

else

begin

writeln('Последовательность невозрастающая');

break

end;

end;

if i=n then writeln('Последовательность возрастающая');

End.




Найти самую большую цифру
целого числа.


Program
rar;

uses
crt;

var
n:longint;

b:byte;

Помогите пожааалуйста,вообще нереально сделать(задачи зависят друг от друга) 1.заполнить массив из 100 элементов случайными числами.вывести на

экран с 20 по 50 в строку через пробел

2.для первыз десяти элементов найти среднее арифмитическое

3.вывести на экран только четные элементы с 1 по 10 элементы массива

4.найти сумму нечетныз значений с 20 по 50 элемент

5.найти количество элементов кратныз заданному числу,введёного с клавиатуры среди всез элементок линейного массива

Помогите пожалуйста!

1.С клавиатуры вводится целое двузначное число.Вывести на экран сумму его цифр.
2.Найти все двузначные числа,в которых есть цифра 4.
Прошу,помогите.



Вы находитесь на странице вопроса "Ребят, помогите, пожалуйста, с задачей: ДАНО ЧЕТЫРЁХЗНАЧНОЕ ЧИСЛО,ВЫВЕСТИ НА ЭКРАН КУБЫ ЦИФР ЭТОГО ЧИСЛА(PASCAL). Заранее огромное спасибо.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.