Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Имеется целочисленный массив состоящий из N элементов (N - чётное) а)Найти сумму первых N/2 элементов. б)Найти сумму элементов стоящих на чётных

5-9 класс

позициях. в) Найти произведение элементов стоящих на нечётных позициях. г) Найти сумму чётных элементов стоящих на чётных позициях.

M3lkiy 31 янв. 2016 г., 18:44:16 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rinfox
31 янв. 2016 г., 21:34:09 (8 лет назад)

а)
uses crt;
var n,i,sum:integer;
a:array[1..100] of integer;
begin
writeln('N?');
read(n);
writeln('Элементы?');
for i:=1 to n do
read(a[i]);
for i:=1 to n div 2 do
sum:=sum+a[i];
writeln(sum);
end.
б)
uses crt;
var n,i,sum:integer;
a:array[1..100] of integer;
begin
writeln('N?');
read(n);
writeln('Элементы?');
for i:=1 to n do
begin
read(a[i]);
if i mod 2=0 then 
sum:=sum+a[i];

Ответить

Другие вопросы из категории

Задание 4. Калорийность обеда 1.Задание 4. Калорийность обеда 1. Продумайте структуру и создайте таблицу (в программе Microsoft Excel) для решения

следующей задачи: Из одного грамма углеводов человек получает 4,1 ккал, из одного грамма жиров — 9,3 ккал, из одного грамма белков — 4,2 ккал. Порция борща со свежей капустой содержит 3,6 г белков, 12 г жиров и 24 г углеводов. Порция гуляша — 24,3 г белков, 24 г жиров, 7 г углеводов. Порция картофеля с маслом — 2,7 г белков, 7 г жиров и 39 г углеводов. Порция компота из свежих фруктов содержит 0,4 г белков, 36 г углеводов, не содержит жиров. Сколько энергии вы получите: 1) отдельно из белков, жиров и углеводов, содержащихся в каждом блюде; 2) из каждого блюда; 3) отдельно из белков, жиров и углеводов, входящих в обед; 4) из всего обеда? 2. Введите необходимые формулы и проведите по ним расчеты. 3. Сохраните таблицу в собственной папке под именем Калорийность. Мне надо таблицу, чтобы все понятно было. Если есть ссылки на решение или файлы киньте пожалуйста

Читайте также

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти

среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.

ОООЧЕНЬ НУЖНА ПОМОЩЬ!! Имеется целочисленный массив ,состоящий из 10 элементов,элементы вводятся с клавиатуры , найти:

а) кол-во элементов кратных пяти
б) кол-во двузначных отрицательных чисел
P.S. это должны быть две задачи

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.



Вы находитесь на странице вопроса "Имеется целочисленный массив состоящий из N элементов (N - чётное) а)Найти сумму первых N/2 элементов. б)Найти сумму элементов стоящих на чётных", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.