Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Найти произведения цифр входящих в состав данного трёхзначного числа. Дам 20 баллов.

5-9 класс

Luikoptevo 02 сент. 2014 г., 3:04:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lenohec
02 сент. 2014 г., 3:54:49 (9 лет назад)

Program enot;
Var i,a,b,s:integer;
begin
read(a);
b:=1;
s:=1;
for i:= 1 to 3 do
begin
b:=a mod 10;
s:=s*b;
a:=a div 10;
end;
write(s);
end.

Ответить

Другие вопросы из категории

Клиент внёс в банк Х рублей.Каждый месяц эта сумма увеличивается на Р процентов.

Сколько будет у клиента денег через два месяца,три месяца,через полгода?

программа против вирусов
У человека имеется 3 белых носка, 3 черных носка, 3 розовых носка и 3 голубых носка в комоде. Какое минимальное число носков он должен вытащить из своего

комода, чтобы составить три целых пары, если учесть, что он не может видеть их цвет?

Читайте также

Дано трёхзначное число. Напишите программу, которая определяет:

а) есть ли среди цифр заданного целого трёхзначного числа одинаковые;
пример входных данных: 123; 121; 222
пример выходных данных: нет; да; да
б) является ли число "перевёртышем", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево.

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC

Выполнить задания, связанные с Turbo Pascal: 1) Какой оператор позволяет менять значения переменных и вычислять

значения выражений?

2) Выполнить алгоритм при x=345:

Начало

ввод x

a=x div 100

b=x div 10 mod 10

c=(a+b)/2

вывод a

вывод b

вывод c

конец

3) Что появится на экране после выполнения фрагмента программы:

a:=7;

b:=5;

a:=a-b;

Writeln(b-a*2);

Writeln('a=',a,'b=',b);

4) Дана сторона квадрата, найти его периметр.

5) Дано трёхзначное число. В нём зачеркнули последнюю справа цифру и приписали её в начале. Найти полученное число.

*Задачи 4 и 5 решить на языке программирования, используя математические функции.



Вы находитесь на странице вопроса "Найти произведения цифр входящих в состав данного трёхзначного числа. Дам 20 баллов.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.