Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Работница теплицы готовит раствор для подкормки растений. В ее распоряжении имеются стеклянные банки 1, 2, и 3 литра. Какое наименьшее количество банок вод

5-9 класс

ы потребуется для подготовки N(N<100) литров раствора?
Пример:
Входные данные = 10
Выходные данные= 3 3 3 1

Bisalov97 23 окт. 2013 г., 22:14:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ВадимБогатиков
24 окт. 2013 г., 1:13:18 (10 лет назад)

var
  x, y: byte;

begin
  readln(x);
  repeat
    if (x div 3 > 0) then
    begin
      write(3:2);
      x -= 3;
    end
    else
    if (x div 2 > 0) then
    begin
      write(2:2);
      x -= 2;
    end
    else
    if (x > 0) then
    begin
      write(1:2);
      x -= 1;
    end;
  until (x = 0);
end.

Ответить

Другие вопросы из категории

Миша решил называть числа «приятными», если в их записи участвуют только четные цифры. Помогите ему сосчитать количество

4-значных «приятных» чисел. Решение обязательно, не только ответ. Заранее спасибо большое

Люди очень срочно решите пожалуйста задачу на Паскале:

их 4 штуки!
1.дан массив тз N элементов. Есть ли в нем чётные элементы, которые кратны заданному числу K.
2. Дан массив из Nэлементов. Посчитать, сколько элементов массива равных минемальному.
3. Сформировать массив из Nэлементов: 10 12 16 22 30 40.
4. Дан массив из Nэлементов. Перемножить минемальные элементы на 2.
Heeelp!

Читайте также

Помогите пожалуйста, срочно надо Составь программу на Pascal для этой задачи:

С кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг. Какое наименьшее количество коробок потребуется для перевозки N килограмм конфет?

Профессор Самоделкин решил изготовить объемную модель кубиков из спичек, используя спички для рёбер кубиков. Длина ребра каждого кубика равна одной спичке

. Для построения модели трех кубиков он использовал 28 спичек. Какое наименьшее количество спичек нужно Самоделкину для построения модели из N кубиков? Все числа в задаче не превышают 2·109.

Метеорологическая станция ведет наблюдение за температурой воздуха

Считается, что температура должна быть представлена целым числом. При этом она не может опускаться ниже минус 14 градусов и подниматься выше плюс 18 градусов. Каждое значение температуры записывается при помощи минимально возможного количества бит.За некоторый период времени станция сделала 144 измерения. Каков информационный объем результатов наблюдений? Ответ укажите в байтах.
Ответ:
Question 4
Баллов: 1
Световое табло состоит из лампочек, каждая из которых может находиться в двух состояниях (включено или выключено). Сколько различных сигналов можно передать при помощи такого табло, если на нем 7 лампочек?
Ответ:
Question 5
Баллов: 1
В двенадцатиэтажном одноподъездном доме устанавливают цифровой домофон. Какое минимальное количество бит потребуется для кодирования номера каждой квартиры, если на каждом этаже 8 квартир?
Ответ:
Question 6
Баллов: 1
Световое табло состоит из лампочек, каждая из которых может находиться в двух состояниях (включено или выключено). Какое наименьшее количество лампочек должно находиться на табло, чтобы с его помощью можно было передать 196 различных сигнала?
Ответ:
Question 7
Баллов: 1
Метеорологическая станция ведет наблюдение за направлением ветра. Результатом одного измерения является одно из восьми возможных направлений, которое записывается при помощи минимально возможного количества бит. Станция сделала 216 измерения. Каков информационный объем результатов наблюдений? Ответ укажите в байтах.
Ответ:
Question 8
Баллов: 1
Алфавит некоторого языка состоит из 54 символов. Оцените информационный объем сообщения в БАЙТАХ длиной в 120 символов.
Ответ:
Question 9
Баллов: 1
Обычный дорожный светофор без дополнительных секций подает 6 видов сигналов (непрерывный красный, непрерывный желтый, непрерывный зеленый и мигающий красный,мигающий желтый,мигающий зеленый). Электронное устройство управления светофором последовательно воспроизводит записанные сигналы. Подряд записано 72 сигнала светофора. Оцените данный информационный объем в байтах.
Ответ:
Question 10
Баллов: 1
Алфавит некоторого языка состоит из 7 символов. Оцените информационный объем сообщения в БИТАХ длиной в 21 символ.
Ответ:
Question 11
Баллов: 1
Обычный дорожный светофор без дополнительных секций подает 6 видов сигналов (непрерывный красный, непрерывный желтый, непрерывный зеленый и мигающий красный,мигающий желтый,мигающий зеленый). Электронное устройство управления светофором последовательно воспроизводит записанные сигналы. Подряд записано 45 сигналов светофора. Оцените данный информационный объем в битах.
Ответ:
Question 12
Баллов: 1
Световое табло состоит из лампочек, каждая из которых может находиться в двух состояниях (включено или выключено). Какое наименьшее количество лампочек должно находиться на табло, чтобы с его помощью можно было передать 64 различных сигнала?
Ответ:

№1.

Светлое табло состоит из лампочек, каждая из которых мажет находиться в двух состояниях: "включено" или "выключено". Какое наименьшее количество лампочек должно находиться на табло, чтобы с его помощью можно было передавать 15 различных сигналов?
Дано: Решение:

№2.
Для передачи секретного сообщения на английском языке использовался равномерный двоичный код: каждый символ исходного сообщения кодировался двоичной цепочкой одной и той же минимально возможной длины. Какова длина двоичного кода, если исходное сообщение состояло из 20 символов?
Дано: Решение:

Заранее спасибо!
Если можно напишите пожалуйста понятным языком ( я в информатике не понимаю)

Срочно !!!!

Определите, кто играет роль управляющего и кто (или что) играет роль объекта управления в следующих системах: школа, класс, самолет, стая волков, стадо коров.(1.Директор - учителя, 2. учитель - ученики, 3. пилот - самолёт, 4. вожак - стая, 5. пастух - коровы.)

Для систем управления, выявленных в предыдущей задаче, назовите некоторые команды управления и скажите, в какой форме они отделяются



Вы находитесь на странице вопроса "Работница теплицы готовит раствор для подкормки растений. В ее распоряжении имеются стеклянные банки 1, 2, и 3 литра. Какое наименьшее количество банок вод", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.