Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Сколько раз по программе выполнится команда ADD, если слагаемые в D=35 и в E=F7

10-11 класс

PolinaMikaelyan 05 июля 2014 г., 12:28:42 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ritapilicheva
05 июля 2014 г., 14:05:30 (9 лет назад)

Десять раз. Определенно

Ответить

Другие вопросы из категории

Помогите с Pascal, пожалуйста. Завтра нужно домашку сдать, а я ничего не понимаю :(

Решите хотя бы одну, или две)
Вот задачи:
1. Заполнить одномерный массив, размерностью 15 по следующему правилу: на нечетном месте должен стоять элемент от 10 до 100, а на четном месте должен находиться нечетный элемент на том же промежутке.
2. Дан одномерный массив, заполненный целыми случайными числами. Определить, на сколько больше сумма четных элементов по сравнению с суммой элементов кратных 3.
3. Дан двумерный массив, размерностью 6х7. Определить, сумма каких элементов больше: 2-го столбца или 3-ей строки.

Написать программу вНаписать программу в паскале.Проверить правильность решения примера (вида 2+3=5):

1) Пример содержит два многозначных числа (123+45=168)
2) Содержит любое количество многозначных чисел (123+45+23+1+1678 + ... = ...)

Читайте также

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

Сколько раз выполнится тело цикла в каждом фрагменте программы?

1. For i :=1 to 7 do S := S + i * i;
2. For x := -3 to 5 do 5 do K := K+ABS(X);
3. For a := 10 downo 2 do P :=P*a;
4. For i := 2 to 6 do
begin
K:=K+1;
S:=K+i;
end;

Сколько раз выполнится тело цикла, и чему будут равны значения встречающихся в программе переменных после выполнения каждого фрагмента программы?

5. i :=2; S:=0;
While S<0 do begib S:= S+i; i:+2; end;

6. x:=1 ; S:=10 ;
While x <=10 do x:=x*2 ;
S:= S+x

7. a:=0; S:=0 ;
While a> 0 do S :=S +a;
a:=a+1;

8 . a:=1;
Repeat
R := 2*a;
a:= a+1 ;
until R < 1;

9. a:=1; b:=1;
While a+b < 8 do begin a :=a+1; b := b+2 end;
S := a+b;

10. S:=0; P:= 10; k:= 1;
Repeat
S:= S+k*k;
k :=k+2;
until S > P;

11. For i :=2 to 6 do begin
K:= K+1; S:= K+i;
end;

12. for i:= 1 to 4 do S :=S+i*i; S: S*2;

ПОМОГИТЕ!ПОЖАЛУЙСТА! 1. Во сколько раз увеличится информационная емкость файла, содержащего растровое изображение, если повысить глубину его цвета со

стандарта «черно-белое» до стандарта «65 536 цветов»? 1) 8 2) 16 3) 32 4) 64 2. Во сколько раз увеличится информационная емкость файла, содержащего растровое изображение, если повысить глубину его цвета со стандарта «черно-белое» до стандарта «4 294 967 296 цветов»? 1)8 2)16 3)32 4)64 3. Какой объем памяти видеокарты займет изображение 12-разрядного файла типа BMP, экранный размер которого 1024 х 768 пикселей? 1) 3 Кбайт 2) 24 Кбайт 3) 3 Мбайт 4) 24 Мбайт

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3

Исполнитель Маляр стоит на клетчатом поле. Маляр может выполнять команды вправо, влево, вверх, вниз. При выполнении любой из этих команд он

перемещается на одну клетку соответственно вправо →,влево ←, вверх ↑, вниз ↓ по полю. Все клетки, через которые проходит Маляр (включая начальную и конечную), он закрашивает. Дана программа для этого исполнителя: НАЧАЛО ПОВТОРИТЬ 100 РАЗ вправо вправо влево влево вверх вправо вниз КОНЕЦ КОНЕЦ Сколько клеток будет закрашено в результате выполнения этой программы? Ответ обоснуйте.



Вы находитесь на странице вопроса "Сколько раз по программе выполнится команда ADD, если слагаемые в D=35 и в E=F7", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.