Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите сотавить программу Турбо Паскале. Дано целое число А. Если значение А>0, то необходимо увеличить его на единицу. Разобрать схему

10-11 класс

алгоритма для решения этой задачию Протестировать алгоритм для А=5,А=-4,А=0 в

Dgengo83 02 марта 2014 г., 16:13:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alex1512
02 марта 2014 г., 18:28:55 (10 лет назад)

var a:longint;
begin
read(a);
if a>0 then
a:=a+1;
end.

Ответить

Другие вопросы из категории

Приведен текст программы на языке Pascal:

Var n, s : Integer;
Begin
Readln (n);
s:=0;
While n>0 Do
Begin
s:=s+n mod 10;
n:=n div 10
End;
Writeln (s)
End.
Расположите перечисленные исходные данные для этой программы (значения переменной n) в порядке УБЫВАНИЯ результатов (значения переменной s) работы программы.
1) 95
2) 502
3) 10023
4) 8
5) 613

помогите как можете
Паскаль

Проверить, будет ли файл, состоящий из целых чисел симметричен.
(первый символ должен быть равный последнему, второй символ равен предпоследнему и т.д)

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

помогите написать программы

1. Дано целое число N (> 0). Если N — нечетное, то вывести произведение 1•3•...•N; если N — четное, то вывести произведение 2•4•...•N.
2. Вывести на экран таблицу значений функции x2 на отрезке[0,1] с шагом 0.1.

Написать программу в паскале: Даны целое n>0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. Найти

величину наибольшего среди отрицательных чисел этой последовательности.

Запросить с консоли целое число и проверить значение бита с указанным номером в этом числе. Результат такой проверки вывести на консоль. Для удобства

разрешается запрашивать указанное число в восьмиричной или шестнадцатиричой системе счисления. При выполнении задания важно обратить внимание на грамотный выбор типа данных анализируемого числа

Помогите надо написать программу в паскале. 1)координаты двух различных полей шахматной доски x1, y1,x2, y2 (целые числа, лежащие в диапазоне 1–8).

Проверить истинность высказывания: «Ладья за один ход может перейти с одного поля на другое». 2) Дано трехзначное число. Проверить истинность высказывания: «Все цифры данного числа различны». 3)Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения. Вывести новые значения переменных A и B.



Вы находитесь на странице вопроса "Помогите сотавить программу Турбо Паскале. Дано целое число А. Если значение А>0, то необходимо увеличить его на единицу. Разобрать схему", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.