Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

напишите програму нахождения всех натуральных делитей числа (натурального)

10-11 класс

Dima20505 23 июля 2013 г., 2:37:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Student123
23 июля 2013 г., 4:12:46 (10 лет назад)

program zadacha;
uses crt;
var n, k: integer;
begin
clrscr;
write ('vvedite chislo: ');
readln (n);
for k:=1 to n do begin
if n mod k = 0 then writeln (k);
end;
readkey;
end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ НАПИСАТЬ В ПАСКАЛЕ :Любое целое число может быть выражено через k троек и m

пятерок: n = k⋅3+m⋅5. Найти для заданного числа n значения k и m.
ЗА РАНИЕ СПАСИБО

Помогите, очень нужно.

Нужно найти переменную i

1.Сколько бит информации содержится в сообщении объемом половина килобайта?

2.Сколько байт информации содержит сообщение объемом 0,25 Кбайт
3.Сколько Кбайт информации содержит сообщение объемом 2^16 бит
4.Сколько Мбайт информации содержит сообщение объемом 2^25 бит?
5.Сколько Гбайт информации содержит сообщение объемом 2^37бит?

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Дано натуральное четырехзначное число. Средствами Microsoft Excel получить число: 1) образуемое при перестановке

первой и второй, третьей и четвертой цифр заданного числа. Например, из числа
5436 получить число 4563.

Решите пожалуйста очень срочно надо

1) Дано четырехзначное число. Верно ли, что среди его цифр есть кратные трем
2) Даны три целых числа. Вывести среднее значение числа (средним числом назовем то, которое меньше наибольшего, но больше наименьшего числа)
3) Напишите эффективную программ, которая по двум данным натуральным числам х и у, не превосходящим 10000, подсчитывает количество натуральных чисел, заканчивающихся нулем, на отрезке [х,у] (включая концы отрезка).



Вы находитесь на странице вопроса "напишите програму нахождения всех натуральных делитей числа (натурального)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.