Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано вещественное число а. Напечатать все значения n ,при которых 1+(1/2)+(1/3)+..+(1/n)<a

10-11 класс

Юли4кA 28 авг. 2013 г., 22:41:55 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dartazovanbrei
28 авг. 2013 г., 23:39:00 (10 лет назад)

program fofgogjoj;
var 
n:integer;
a,s:real;
begin
repeat
Writeln('Введите вещественное число  a');
Read(a);
until a>1;
s:=0;
n:=1;
while s<a-1/n do 
begin 
s:=s+1/n; 
Write(n:4); 
n:=n+1; 
end;
Writeln;
Writeln('s=',s:0:4);
end.


Не советую печатать число большее 10 xD

+ 0 -
Nastya0106200
29 авг. 2013 г., 1:06:20 (10 лет назад)

паскаль?

+ 0 -
ученика23
29 авг. 2013 г., 2:32:26 (10 лет назад)

lf

+ 0 -
Myeternity
29 авг. 2013 г., 5:29:09 (10 лет назад)

да

Ответить

Другие вопросы из категории

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

дано вещественное число х.Найдите значения полинома:

4х^5-х^3+х^2-х+4

1. Дано шестнадцатиричное число 12CD. Получить его двоичный аналог.

2. Дано десятичное число X=563. Представить его в ячейке.
3. Дано десятичное число X= -62. Представить его в восьмиразрядной ячейке.
4. Дана шестнадцатеричная запись числа X=FB32 в ячейке. Получить исходное число в десятичной системе.

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE



Вы находитесь на странице вопроса "Дано вещественное число а. Напечатать все значения n ,при которых 1+(1/2)+(1/3)+..+(1/n)&lt;a", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.