Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Подскажите как решить.

10-11 класс

Одновремный массв, состоящий из n положительных и отрицательных элементов, заполняется случайным образом. Составить программу, реализующую поиск первого отрицательного элемента и меняющую его с местами с последним элементом массива. Вывести результат на экран.

Elasaroyan2002 11 июля 2014 г., 19:31:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kolya132
11 июля 2014 г., 22:10:47 (9 лет назад)

const z = 10;
var
  a: array[1..z] of integer;
  i, n, tmp: integer;
begin
  for i := 1 to z do begin
    a[i] := random(6) - 4;
    write(a[i], ' ');
  end;
  writeln;
  for i := 1 to z do begin
    if(a[i] < 0) and (n = 0) then begin
      tmp := a[z];
      a[z] := a[i];
      a[i] := tmp;
      inc(n);
    end;
    write(a[i], ' ');
  end;
end.

Ответить

Другие вопросы из категории

Нормализуйте манттссу в числах

А) 0,0041 10 в нижнем правом углу маленькая 2
Б)-16,78 10 в нижнем правом углу маленькое -3

ПОМОГИТЕ! Нужно написать программу в паскале. 1. Поменяйте местами первый элемен массива А(8) с наибольшим элементом, а

последний - с наименьшим элементом массива. Случайные числа в [10;99]

2. Посчитайте сумму чётных элементов массива А(8). Случайные числа в [1;9]

3. Найдите номер нулевого элемента данного одномерного массива А(10). Случайные числа в [-10;10]

Читайте также

Здавствуйте ребята!Помогите пожалуйста решить,перевесети из двочного кода в десятичный код.Числа записаны в парах : 1)101 101 2)1000

1000

3)1001 1000

4)1011 110

5)1100 110

6)1100 111

7)1011 111

8)1011 10

9)1001 10

10)1001 11

11)1010 11

12)1010 100

13)111 100

14)111 10

15)101 10

16)101 11

17)110 11

18)110 1001

19)111 1001

20)111 1000

21)10 1000

22)10 1001

23)11 1001

24)11 110

25)100 101

Или подскажите как решать хотя бы:))Заранее спасибо.

Подскажите, как решить на паскале?

Участок сада треугольной формы с длинами границ a=3, b=4, c=5. Найдите длину ограды и количество удобрений нужных для участка.

ПОДСКАЖИТЕ ПОЖАЛУЙСТА КАК РЕШАЕТСЯ ЭТО ЗАДАНИЕ

Для вычисления в ячейкеE7 количества студентов, сдавших сессию
только на четыре и пять, следует выполнить одну из следующих
последовательностей действий:
1) в ячейкуE2 вписать формулу ЕСЛИ(И(И(B2>3; C2>3); D2>3); 1;0);
скопировать ее в диапазонE3:E6;
в ячейкуE7 вписать формулу СУММЕСЛИ(B2:B6;">3";E2:E6)
2) в ячейкуE2 вписать формулу ЕСЛИ(И(B2>3; C2>3); 1;0);
скопировать ее в диапазонE3:E6;
в ячейкуE7 вписать формулу СУММ(E2:E6)
3) в ячейкуE7 вписать формулу СУММЕСЛИ(B2:B6;">3";E2:E6)
4) в ячейкуE2 вписать формулу ЕСЛИ(И(И(B2>3; C2>3); D2>3); 0; 1);
скопировать ее в диапазонE3:E6;
в ячейкуE7 вписать формулу СУММ(E2:E6)
5) в ячейкуE2 вписать формулу ЕСЛИ(И(И(B2>3; C2>3); D2>3); 1;0);
скопировать ее в диапазонE3:E6;
в ячейкуE7 вписать формулу СУММ(E2:E6)



Вы находитесь на странице вопроса "Подскажите как решить.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.