Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Подскажите, как решить на паскале?

10-11 класс

Участок сада треугольной формы с длинами границ a=3, b=4, c=5. Найдите длину ограды и количество удобрений нужных для участка.

Ildargalimov20 17 авг. 2013 г., 22:54:44 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Simonovasasha022
18 авг. 2013 г., 1:07:34 (10 лет назад)

program zadacha;
uses crt;
var a, b, c: integer;
u, p, s: real;
begin
clrscr;
write ('vvedite kolichestvo udobrenii, nuzhnyh dlya 1 m^2: ');
readln (u);
write ('vvedite storony uchastka: '); // таким образом можно ввести любые
// стороны, не только 3, 4 и 5
readln (a, b, c);
//  можно сразу написать a:=4; b:=3; c:=5;
p:=a+b+c;
writeln (' dlina ogrady - ', p:0:2);
p:=p/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c)); // вычисление площади по формуле Герона
u:=u*s;
writeln ('kolichestvo trebuemyh udobrenii - ', u:0:2);
readkey;
end.

+ 0 -
Rinat95
18 авг. 2013 г., 2:56:34 (10 лет назад)

А какое количество удобрений нужно на единицу площади, на квадратный метр, например?

+ 0 -
Mariyasirenko
18 авг. 2013 г., 4:02:16 (10 лет назад)

я еще раз пересмотрела условие, этого не сказано.

+ 0 -
Romario390
18 авг. 2013 г., 5:53:12 (10 лет назад)

Ладно, пусть будет 1 кг на квадратный метр, если что - измените.

+ 0 -
Дианочка8216611
18 авг. 2013 г., 7:40:29 (10 лет назад)

В общем, эту переменную можно будет ввести с клавиатуры

+ 0 -
Ирина2583022
18 авг. 2013 г., 9:54:35 (10 лет назад)

спасибо огромное *-*

Ответить

Другие вопросы из категории

Читайте также

Помогите решить на паскале

______________________________________
В сказочном Солнечном городе живут трое братьев: Ниф-Ниф, Наф-Наф, и Нуф-Нуф. Известно, что у каждого из них есть какое-то количество денег. Так случилось, что после физкультуры они перепутали пиджаки, в которых и лежали деньги. Однако зная о возможной путанице родители пришили бирки с именами. Помогите определить сколько же денег было до физкультуры у братьев, зная что Нуф-Нуф пришел домой в пиджаке Ниф-Нифа, а Наф-Наф в пиджаке Нуф-Нуфа. Входные данные:

В единственной строке входного потока, через пробел записано три числа в диапазоне от 1 до 10^9. Первое число это количество денег, которое обнаружил Ниф-Ниф в карманах придя домой. Второе - сколько стало у Наф-Нафа. И третье сколько принес домой Нуф-Нуф.

Выходные данные:

В первую строку выходного потока необходимо вывести сколько денег было у Ниф-Нифа, во вторую - сколько у Наф-Нафа, а в третью - сколько у Нуф-Нуфа.

Пример входного файла (input.txt): 32 22 54 Пример выходного файла (output.txt): 54 32 22

Здавствуйте ребята!Помогите пожалуйста решить,перевесети из двочного кода в десятичный код.Числа записаны в парах : 1)101 101 2)1000

1000

3)1001 1000

4)1011 110

5)1100 110

6)1100 111

7)1011 111

8)1011 10

9)1001 10

10)1001 11

11)1010 11

12)1010 100

13)111 100

14)111 10

15)101 10

16)101 11

17)110 11

18)110 1001

19)111 1001

20)111 1000

21)10 1000

22)10 1001

23)11 1001

24)11 110

25)100 101

Или подскажите как решать хотя бы:))Заранее спасибо.

Подскажите как решить.

Одновремный массв, состоящий из n положительных и отрицательных элементов, заполняется случайным образом. Составить программу, реализующую поиск первого отрицательного элемента и меняющую его с местами с последним элементом массива. Вывести результат на экран.



Вы находитесь на странице вопроса "Подскажите, как решить на паскале?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.