Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль

5-9 класс

Даны целое число k (1≤ k≤ 180) и последовательность цифр 10111213...9899, в которой выписаны подряд все двухзначные числа. Определить k-ю цифру.

Annalir 15 мая 2014 г., 20:20:13 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nikita311003
15 мая 2014 г., 21:32:46 (10 лет назад)

var
   k,i:integer;
   s,x:string;
begin
for i:=10 to 99 do  s:=s+IntToStr(i);
writeln(s);
write('Введите число k: ');
readln(k);
x:=s[k];
writeln(k,'-я цифра: ',x)
end.

Ответить

Другие вопросы из категории

1.объём сообщения равен 11Кбайт.Сообщение содержит 11.264 символа. Ответ мощность алфавита с помощью которого было записано сообщение =256,нужно написать

решение задачи полностью.
2.Дан текст из 600 символов . Известно ,что символы берутся из таблицы размером16*32.Ответ информационный объём текста в битах =5.400бит.нужно написать решение задачи полностью.

Дан текст: Он, словно слон в посудной лавке, неповоротлив и смешон, и, окончательно смутившись, нам всем представился

"Антон".

Сколько замен будет выполнено в этом тексте при выполнении автоматической замены фрагмента "он" на "ОН"?

Помогите решить кроссворд! Please!

По горизонтали:
1) С его помощью можно предупредить об опасности (4 буквы)
2) Звуки этого инструмента способны донести сигнал на несколько километров (7 букв)
3) Самое современное средство получения информации (8 букв)
4) Приёмник информации имеющийся в каждом доме (9 букв)
5) Связь открытая нашим соотечественником в 1895 году (10 букв)
6) Название помехоустойчивого кода (5 букв)

По вертикали:
1) Техническое средство, с помощью которого происходит передача информации

Заранее Спасибо!

информатика 8 классСРОЧНО!!
Сравнить: 2048 бит и ¼ Кбайта.

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Паскаль, в его первоначальном виде, представляет собою чисто процедурный язык.

Простейшая программа на Паскале будет выглядеть следующим образом:
program upr;
begin
writeln ( ? ); {оператор вывода строки}
end.
Определи, какая фраза пропущена на месте вопросительного знака?
’Hello, World!’
“Lorem ipsum”
Just Another Perl Hacker

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!

ПРОГРАММИРОВАНИЕ,ПАСКАЛЬ.РЕБЯТА,УМОЛЯЮ,ПОМОГИТЕ.

Задали написать программу на язвке паскаль:вычислить и вывести на экран 8 первых элементов ряда если каждый элемент задан формулой а1= i/sin*i



Вы находитесь на странице вопроса "Паскаль", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.