Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дано четырехзначное число.найти сумму квадратов второй и третьей цифры

10-11 класс

Duli161198 23 мая 2013 г., 1:24:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rif712012
23 мая 2013 г., 4:18:48 (10 лет назад)

Var n,n1,n2,n3,n4,sum:integer;
Begin 
readln(n);
     n1:=n div 1000; 
         n2:=n div 100; 
         n2:=n2 mod 10;   
              n3:=n div 10;   
              n3:=n3 mod 10;     
                   n4:=n mod 10;       
n2:=n2*n2; 
n3:=n3*n3; 
  sum:=sum+n2+n3; 
    writeln('sum=',sum);

end.

Ответить

Другие вопросы из категории

Помогите решить задачу в паскаль.

S:=1+√2+√3+√4+...+√V
1<=V<=120

Напишите программу на языке Паскаль, для решения следующей задачи:

Для любого четырехзначного вводимого числа найти сумму второй и предпоследней цифры).
(Подсказка. Используйте тип данных integer и операции div и mod)

помогите пожалуйста а2..........

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

Дано натуральное число N. Найти наименьшее число М (N < M < 2N) которое делится на сумму цифр числа N (без остатка). Если такого числа нет, то

вывести слово «нет». Пример. N = 12 345, М = 12360. Число 12 360 делится на число 15 — сумму цифр числа N



Вы находитесь на странице вопроса "Дано четырехзначное число.найти сумму квадратов второй и третьей цифры", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.