Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Это Паскаль

10-11 класс

тут дается функция 5*e^(-x^2/2)

Djekmen 26 дек. 2016 г., 12:43:30 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mvkysnaya
26 дек. 2016 г., 13:18:37 (7 лет назад)

Если что, проверялось только в pascal abc.
uses crt;
var x,a,b,h:real;
begin
writeln('Input a,b,h:');
read(a,b,h);
writeln('x','   ','f(x)');
x:=a;
while x<=b do
begin
writeln(x,'   ',(5*power(e,(-x*-x)/2)):0:2);
x:=x+h;
end;
end.

Ответить

Другие вопросы из категории

1.Выполнить отладку следующей программы:

A) SCREEN 9
FOR X=1 TO 640
CLS
CIRCLE(Х+I, 100),30,2
FOR J=1 T0 5000
NEXT J
CIRCLE(Х+1,100),30,0
NEXT X
Б) Изменить эту программу таким образом, чтобы окружность двигалась по экрану сверху вниз.

Pascal.Не могу нормально вывести S которое вычисляется в процедуре. Если просто выводить переменную S то показывает 0. Как нормально вывести S? Программа

считает всё правильно, но с выводом проблемы.
program kr_pr_4;

procedure fgerona(a,b,c:real);
var
p,s:real;
begin
p:=(a+b+c)/2;
s:= sqrt(p*(p-a)*(p-b)*(p-c));

end;

var
a,b,c,s,p:real;
begin
writeln('Введите сторону А');
read(a);
writeln('Введите сторону B');
read(b);
writeln('Введите сторону C');
read(c);
fgerona(a,b,c);
writeln('S = ',s);
end.

Читайте также

Помогите!!!!

Прошу помогите, умоляю.........
Это Паскаль.....

Помогите пожалуйста - это Паскаль
Помогите с паскалем, у меня практика, это очень срочно...

1. Вычислите выражение при заданных константах: A=16.5; b=3.4; x=0.61; S=x^3tg^2(x+b)^2+a/√x+b; Q=bx^2-a/e^a^x-1





2.

Составить программу вычисления значения функции. На экран вывести функцию (записанную на Паскале) вместе с результатом.


у={a+b+cx^2,если 1<=x<2
(a*sin(xb))^2,если 2<=x<3
под корнем |a+bx^2|+c ,если 3<=x<4
a*ln|b+c/2x| ,если 4<=x<5
e^esinx+c^3 ,если 5<=x<6


Пожалуйста...



Вы находитесь на странице вопроса "Это Паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.