Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

помогите кто может !!! хелп

5-9 класс

исламчик11 23 окт. 2014 г., 8:33:05 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
невил
23 окт. 2014 г., 10:40:07 (9 лет назад)

1)program z1;
var  
    a:array[1..5]of integer; 
    i,s,j,n:integer;
begin
  n:=0;
  s:=0;
  for i:=1 to 5 do
    begin
      read(a[i]);
      if a[i]>=0 then
      begin
         s:=a[i] mod 4;
         j:=(a[i]-8) mod 10;
      end else
      begin
         s:=a[i] mod -4;
         j:=(a[i]+8) mod -10;
    end;
      if (s=0) and (j=0) then n:=n+1;
    end;
 writeln('Чисел которые оканчиваются на 8 и делятся на 4: ',n,' штук '); 
end.
2)program z2;
var
     

Ответить

Другие вопросы из категории

Автоматическое устройство осуществило перекодировку двух информационных сообщений равной длины из 8-битной кодировки ASCII в 16-битную кодировку

Unicode в одно новое сообщение, которое при этом увеличилось на 240 байт. Какова длина каждого из исходных сообщений в символах?

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal

Читайте также

Разработайте программу,которая безостановочно перемещает Муравья таким образом,что траектория его движения представляет квадрат,стороны которого совпадают

с краями рабочего поля.Начальное положение Муравья - левый верхний угол рабочего поля.СРОЧНО НУЖНО ПОМОГИТЕ КТО МОЖЕТ !

Найдите значение выражения: (А V 1)V( В V 0) Кто не понял V-это знак

"или",то есть дизьюнкция(сложение). Прошу,помогите,кто в теме...

Помогите кто чем может!) НУжно составить программу на языке QBasic. Суть задания: 1)Ввести совю фамилию, имя, отчество как одно текстовое

данное.

а)Определит ьдлину текста.

б)Определить количество букв "b" в нем.

в)Вывести самое длинное слово.

2)Дано предложение. Найти, в каком из слов, состоящего из более чем четырех символов, буква "а" встречается чаще.

По большей части интересует задание 1-в и 2. Буду очень благодарен!!!

пожалуйста срочно помогите, очень прошу

тема у нас Организация ветвлений в Паскале. и так, вопрос:
дано трёхзначное число. если сумма цифр числа кратно 3, тогда перевернуть число, иначе обнулить среднюю цифру
очень срочно, кто может



Вы находитесь на странице вопроса "помогите кто может !!! хелп", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.