Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ПООМГИТЕ ПЛИИИЗ!С клавиатуры вводятся числа до тех пор пока сумма этих чисел не превысится 300. Найдите произведение нечетных чисел.найдите

5-9 класс

кол-во отрицательных чисел.

Vikiliks 18 мая 2013 г., 14:01:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Krahmal2568
18 мая 2013 г., 15:29:55 (10 лет назад)

uses crt;
Var a,x1,x2:integer;
Begin
x1:=1;
x2:=0;
readln(a);
While a<300 do
      Begin
      if (a mod 2<>0) then x1:=x1*a;
      if (a<0) then x2:=x2+1;
      readln(a);
      end;
Writeln('Произведение нечётных чисел=', x1);
Writeln('Кол-во отрицательных чисел=' , x2);
readln;
end.

Ответить

Другие вопросы из категории

НАРООООДД!Решите всё пожалуйста .Просто в конц учебника вопросы и нам их задали .Помогите или проверьте как я решила :

1)На столе стояло 3 стакана с вишней .Оксана съела 1 стакан вишни .Сколько стаканов осталось ?
2)Зажгли 7 свечей ,2 из них погасли .Сколько свечей осталось ?
3)Чем кончается день ?Ночь ? Чем кончается лето и начинается осень ?

Читайте также

Написать программу

4. Компьютер перебирает четные числа до тех пор, пока сума их квадратов не превысит S. Чему равна сумма квадратов?
Подсказка:
Начальное значение переменной цикла – 2. Шаг изменения – 2 (перебираем четные числа).
Считаем сумму квадратов до тех пор пока она меньше или равна S.
Вывод на экран :
Результат:
s =
Тест 1:
Исходные данные:
s = 24
Результат:
s =56
Тест 2:
Исходные данные:
s = 85
Результат:
s =120

"сколько лет бабушке?"Компьютер загадывает целое число от 1 до 100. Пользователь вводит с клавиатуры некоторое число и получает один из ответов:"Мое

чило меньше","Мое число больше","Вы угадали".процесс повторяется до тех пор пока не будет угадано число.

помогите на паскале сделать

с клавиатуры вводится число х. если

с клавиатуры вводится число х. если остаток от деления х на 6 равен 2, то значение f(x)=4*x^2 если остаток от деления х на 6 равен 3, то значение f(x) = корень из х , если остаток от деления на 6 =0 то f(x) = x.


Написать программу в паскале используя операторы if и else . Нарисовать блок схему



Вы находитесь на странице вопроса "ПООМГИТЕ ПЛИИИЗ!С клавиатуры вводятся числа до тех пор пока сумма этих чисел не превысится 300. Найдите произведение нечетных чисел.найдите", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.