Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задача!

10-11 класс


1.Дан массив целых чисел, состоящий из 15 элементов. Найти:
1) сумму положительных элементов, значения которых меньше 10 2) вывести индексы тех элементов, значения которых кратны 3 и 5.


2. Определить, есть ли пара соседних элементов с суммой, равной заданному числу.

Lesya270999 28 нояб. 2014 г., 0:18:58 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mоолюск
28 нояб. 2014 г., 1:15:30 (9 лет назад)

var a:array[1..15]of integer;
b:array[1..15]of boolean;
i,s:integer;
begin
for i:=1 to 15 do begin
readln(a[i]);
if a[i]<10 then s:=s+a[i];
if (a[i] mod 3=0) and{or} (a[i] mod 5=0) then b[i]:=true;
end;
for i:=1 to 15 do if b[i]=true write(i,' ');
writeln(s);
end.

 

var a:array[1..15]of integer;
i,k:integer; c:boolean;
begin
readln(k);
for i:=1 to 15 do readln(a[i]);
for i:=1 to 14 do if a[i]+a[i+1]=k then begin writeln('est'); c:=true; break; end;
if c=false then writeln('net');
end.

Ответить

Другие вопросы из категории

Что называется сетевым протоколом

1)договор о подключении к сети
2)перечень устройств для подключения к сети
3)программа для подключения к сети Интернет
4)соглашения и правила о порядке обмена информацией в сети

Даны три числа. Первое уменьшили на 10, второе увеличили в 3 раза, а третье

возвели в третью степень. Составьте программу, вычисляющую произведение
полученых после преобразования чисел.

Читайте также

Задача первая.

Дан массив O ( K ). Заменить все положительные числа квадратом числа,а отрицательные модулем.
Задача вторая.
Дан массив R ( 6 ) .Найти сумму и произведение всех элементов массивов.

Через Qbasic

ОТ CLS ДО ЕND

Задача № 1

Тронувшись с места, автомобиль каждую секунду увеличивает скорость на а км/ч.
На этом участке дороги существует ограничение V км/ч. Выяснить, через сколько полных секунд автомобиль превысит предельно допустимую скорость V?
Задача №2
Даны действительные числа а, b, c. Определить, можно ли построить треугольник со сторонами а, b, c или нет
Язык ПАСКАЛЬ =)

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Помогите пожалуйста с задачей по информатике!Без массива!Напишите в паскале!Очень надо!!

Опишите этапы решения на компьютере задачи нахождения значения a^b для целых чисел 0<a,b<10.

реализовать задачу на компьютере, используя операторы цикла и вложеннные операторы цикла.

задача. даны площади нескольких квадратов. найти длину диагонали самого большого из них.



Вы находитесь на странице вопроса "Задача!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.