Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составьте программу, которая запрашивает пол учеников ('ж'или 'м') и их количество(от 5 до 30) и выдаёт сообщение. Протокол: Введите пол и количе

10-11 класс

ство: ж 13 В классе сейчас тринадцать девочек

На Паскале

Skate4500 11 июля 2013 г., 16:18:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
двоишник2222
11 июля 2013 г., 17:55:49 (10 лет назад)

Ох и намудрил с этой программой))

 

program school; 
var a:char;
b:real;
c,d:boolean;
begin
Writeln ('Введите пол (м или ж) и количество учеников');

repeat
write ('Пол - '); readln (a);
if upcase(a)='Ж' then c:=true;
if upcase(a)='М' then c:=true;
if c=true then write else
writeln ('Вы должны ввести использовать символы "м" или "ж"');
until c=true;

repeat
write ('Количество учеников данного пола от 5 до 30 - '); readln (b);
if b<5 then d:=false else d:=true;
if b>30 then d:=false else d:=true;
if d=true then
begin
if upcase(a)='Ж' then writeln ('В классе сейчас ',b,' девоч.');
if upcase(a)='М' then writeln ('В классе сейчас ',b,' мальч.');
end;
until d=true;
end.

+ 0 -
Alia204
11 июля 2013 г., 19:46:24 (10 лет назад)

А я вот так сделал)

Написано в pascal.abc.net

 

Var
x : integer;
sex : char;
function numbers(n: integer): string;
begin
case n of
5: Result := 'пять';
6: Result := 'шесть';
7: Result := 'семь';
8: Result := 'восемь';
9: Result := 'девять';
10: Result := 'десять';
11: Result := 'одиннадцать';
12: Result := 'двенадцать';
13: Result := 'тринадцать';
14: Result := 'четырнадцать';
15: Result := 'пятнадцать';
16: Result := 'шестнадцать';
17: Result := 'семнадцать';
18: Result := 'восемнадцать';
19: Result := 'девятнадцать';
20: Result := 'двадцать';
21: Result := 'двадцать один';
22: Result := 'двадцать два';
23: Result := 'двадцать три';
24: Result := 'двадцать четыре';
25: Result := 'двадцать пять';
26: Result := 'двадцать шесть';
27: Result := 'двадцать семь';
28: Result := 'двадцать восемь';
29: Result := 'двадцать девять';
30: Result := 'тридцать';
31: Result := 'тридцать один';
32: Result := 'тридцать два';
33: Result := 'тридцать три';
34: Result := 'тридцать четыре';
35: Result := 'тридцать пять';
end;
end;
begin
writeln ('Введите пол и количество:');
Readln (sex,x);
write('В классе сейчас ', numbers(x));
if sex = 'м' then write(' мальчиков')
else if sex = 'ж' then write(' девочек');
end.

 

 

 

 

Ответить

Другие вопросы из категории

Помогите пожалуйста найти информацию! Тема:Организация работы с сетевыми

информационными ресурсами (блогами)

На столе находятся девять листочков с целыми цифрами от 1 до 9. Из этих листочков составляются два целых числа. Одно из них будет числителем, а второе

знаменателем, причем знаменатель всегда состоит из пяти цифр и каждый листочек должен быть использован. Найти количество комбинаций листочков, которые образовали бы дробь, равную 2/7.

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

решить задачу в паскале. С клавиатуры вводится слово. Составить программу, которая запрашивает ввести следующее слово, которое начинается с последней

буквы предыдущего и осуществляет проверку. Результатом программы является сообщение "Правильно" или "Неправильно"

1.Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных

элементов настоящей таблице х [1 .. 10] на 0.

3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат.

4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE



Вы находитесь на странице вопроса "Составьте программу, которая запрашивает пол учеников ('ж'или 'м') и их количество(от 5 до 30) и выдаёт сообщение. Протокол: Введите пол и количе", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.