Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите составить программу, вычисляющую сумму чисел четырехзначного числа. СРОЧНО!!! Помогите!!!

5-9 класс

Makeeva1 24 апр. 2016 г., 21:04:33 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ViVinograd
24 апр. 2016 г., 23:15:05 (8 лет назад)

program gt;
var n,s:integer;
begin
readln(n);
s:=n div 1000+(n div 100)mod 10+(n mod 100)div 10+n mod 10;
writeln(s);
end.

Ответить

Другие вопросы из категории

дано трехзначное число. Напишите программу, которая определяет:

а) есть ли среди цифр заданного целого трехзначного числа одинаковые

пример входных данных: пример выходных данных:

123 нет

121 да

222 да

Помогите пожалуйста!!!!!!!!!!!!!!!!!

Проводятся две лотереи: «1 из 32» и «1 из 64». Сообщение о результатах, какой из лотерей несет больше информации?

Читайте также

Помогите составить программу , вычисляющую сумму квадратов n чётных натуральных чисел

( сейчас прошли циклические алгоритмы, нужна и блок-схема)

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

Помогите составить программу!!!

Срочно!!!
С клавиатуры вводится четырехзначное число. Проверить, делится ли сумма его цифр на 3 и на 9.

Помогите составить программу по Паскалю, пожалуйста.

Клоун
предложил каждому из публики задумать число. Потом он сказал: «Прибавьте к
задуманному числу 5. Теперь из результата вычтите 2. А теперь к результату
прибавьте 7». Потом клоун спросил у желающих, какое число у каждого из них
получилось. Услышав ответ, он немедленно объявлял каждому, какое число тот
задумывал. Составьте программу, которая повторяла бы фокус клоуна.



Вы находитесь на странице вопроса "Помогите составить программу, вычисляющую сумму чисел четырехзначного числа. СРОЧНО!!! Помогите!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.