Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дана последовательность целых положительных чисел.найти произведение только тех из них которые больше заданного числа m.если таких чисел нет,то

10-11 класс

выдать сообщение об этом Паскаль!!! можно с обьяснениями плиз))

Annetakarpova 15 марта 2017 г., 1:38:09 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Grigorii9
15 марта 2017 г., 2:13:06 (7 лет назад)

program test;
var a: array[1..10] of integer;m, i: integer;
total: longint;
begin
   randomize;
   total:=1;

   for i:=1 to 10 do
   begin
      a[i]:=random(20)+1;
      write(a[i], ' ');
   end;

   writeln();
   write('Enter the number: ');
   readln(m);

   for i:=1 to 10 do
   begin
      if a[i] > m then
         total:= total*a[i];
   end;

   if total > 1 then
      writeln('Total = ', total)
   else
      writeln('Error');
   readln;
end.

Ответить

Другие вопросы из категории

В двоичной системе счисления, используя прямой и обратный двоичные

машинные коды, выполнить сложение двух произвольных двузначных чисел,
заданных в десятичной системе счисления. Полученный результат перевести
в десятичную систему счисления (т .е. сделать проверку). Рассмотреть
следующие случаи:
- оба числа положительные;
- первое число положительное, второе – отрицательное;
- первое число отрицательное, второе – положительное;
- оба числа отрицательные.

Написать программу, запрашивающую с клавиатуры целые числа и определяю-щую максимальное и минимальное из них. Окончание ввода – число 0.

Протестиро-вать программу для последовательности: -3 5 6 -11 24 -1 0.

ПАСКАЛЬ

Выполните вычисления:

а) 5573 (в 8 степени ) + 747( в 8 степени)
б) 111000101 ( в 2 степени) - 1110001 ( в 2й степени)

Читайте также

срочно помогите решить! дам много пунктов!!! пожалуйста, зачет по информатике!! в qBasiq Вариант №

1

Дан массив целых чисел, состоящий из 20 элементов. Заполнить его с клавиатуры.

1. Найти:

- сумму элементов, имеющих нечетное значение;

- вывести индексы тех элементов, значения которых больше заданного числа А.

2. Определить, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

1) Определите и выведите на экран количество чисел от 50 до 500, которые делятся на 11 и 13 одновременно. 2) Дан массив целых чисел, состоящий из 100

элементов. Заполнить его с клавиатуры. Найти:

а) удвоенную сумму положительных элементов;

б)вывести индексы тех элементов, значения которых больше значения предыдцщего элемента ( начиная со второго)

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.



Вы находитесь на странице вопроса "дана последовательность целых положительных чисел.найти произведение только тех из них которые больше заданного числа m.если таких чисел нет,то", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.