Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана строка. Указать те слова, которые содержат хотя бы одну букву k. Составить программу на Паскаль. Заранее спасибо ^_^

10-11 класс

091245 03 февр. 2017 г., 6:33:55 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
RuslanMagadan
03 февр. 2017 г., 9:27:20 (7 лет назад)

var s,tmp:string;
     i,n:integer;
     flag,word:boolean;
function letter (const let:char):boolean;
 begin
   if ((let>='a') and (let<='z')) or ((let>='A') and (let<='Z')) then letter:=true
     else letter:=false;
 end;
begin
  readln (s);
  s:=s+' ';
  n:=length(s);
  flag:=false;
  for i:=1 to n do
   begin
     if (letter(s[i])) and (not flag) then
      begin 
        flag:=true;
        tmp:='';
        word:=false;
      end else if (not letter(s[i])) and (flag) then
      begin 
       flag:=false;
       if (word) and (not (tmp='')) then writeln (tmp);
      end;
     if (flag) then
      begin 
        tmp:=tmp+s[i];
        if (s[i]='k') then word:=true;
      end; 
   end;
end.

Ответить

Другие вопросы из категории

Выполните вычисления:

а) 5573 (в 8 степени ) + 747( в 8 степени)
б) 111000101 ( в 2 степени) - 1110001 ( в 2й степени)

Документ объёмом 40 Мбайт можно передать с одного компьютера на другой двумя способами:

А. Сжать архиватором, передать архив по каналу связи, распаковать.
Б. Передать по каналу связи без использования архиватора.
Какой способ быстрее и насколько, если:
- средняя скорость передачи данных по каналу связи составляет 2 в степени 20 бит в секунду;

Читайте также

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
Дана строка русского текста до 60 символов.Слова разделены пробелами.Заменить встречающиеся в строке слова то на слово это.Напечатать исходную и

полученную строки.Напишите,пожалуйста,программу.Составить программу в паскале.

Запись

некоторого натурального числа X в шестнадцатеричной системе счисления имеет
ровно три значащих разряда. Это число увеличили в два раза, и оказалось, что
запись получившегося числа Y в шестнадцатеричной системе также имеет ровно три
значащих разряда, причем сумма цифр шестнадцатеричной записи исходного числа X
равна сумме цифр шестнадцатеричной записи полученного числа Y. Сколько
существует таких чисел X, которые удовлетворяют указанным условиям и при этом
содержат хотя бы одну цифру 2 в своей шестнадцатеричной записи? В ответе
укажите целое число.
Нужно составить программу, которая автоматически переберет все числа от 100 до FFF



Вы находитесь на странице вопроса "Дана строка. Указать те слова, которые содержат хотя бы одну букву k. Составить программу на Паскаль. Заранее спасибо ^_^", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.