Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

как нарисовать слона в паскале. очень надо!!!

10-11 класс

Marinamosina2 08 мая 2015 г., 22:12:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ахметшина3
09 мая 2015 г., 0:16:11 (9 лет назад)

uses  
 graphabc;
begin   setWindowWidth(640);
   setWindowHeight(480);  
 setpencolor(clltgray);  
 circle(186,214,144);  // тело  
 floodfill(186,214,cldkgray);  
 circle(443,178,105);  // голова  
 floodfill(443,178,clltgray);
  circle(348,188,105);  // ухо
 floodfill(348,188,clltgray);  
 

+ 0 -
Tarabanova
09 мая 2015 г., 3:00:23 (9 лет назад)

Комментарий удален

+ 0 -
Lisic22
09 мая 2015 г., 4:00:06 (9 лет назад)

да)

+ 0 -
Fafla1
09 мая 2015 г., 6:00:04 (9 лет назад)

как его сделать написать все действия

Ответить

Другие вопросы из категории

Вы посетили магазин и купили 10 видов товара.В таблицу T[1:10] вы записали количество купленного товара каждого вида.В таблицу C[1:10] записали цены

единиц каждого вида товара соответственно.Составьте алгоритм вычисления общей стоимости всех покупок. Массив в Бейсике

Народ,помогите дорешать задачу на С++,буду благодарен.

- В целочисленном массиве Х(N) удалить все элементы, расположенные между максимальным и минимальным элементами.
- Найти среднее арифметическое элементов массива до и после удаления.
- В программе написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.

из выше перечисленного выводит только средне арифметическое и средне арифметическое между 1 и последним числом.




#include
float srednee(int* a, int min, int max)
{
int s = 0;
for(int i = min; i <= max; i++)
s += a[i];
return s * 1.0 / (max - min + 1);
}
using namespace std;
int min_i(int* a, int n)
{
int m = a[0];
int numb = 0;
for(int i = 1; i < n; i++)
if(m > a[i])
{
m = a[i];
numb = i;
}
return numb;
}
int max_i(int* a, int n)
{

int m = a[0];


int numb = 0;
for(int i = 1; i < n; i++)
if(m < a[i])
{
m = a[i];
numb = i;
}
return numb;
}
using namespace std;
int main()
{
int N;
cin >> N;
int X[N];

for(int i = 0; i < N; i++)
cin >> X[i];
cout << "srednee znachenie vsego massiva: " << srednee(X, 0, N - 1) << endl;
int min = min_i(X, N);
int max = max_i(X, N);
if(min > max)
{
int z = min;
min = max;
max = z;
}
if(max - min == 0 || max - min == 1)
cout << "srednee znachenie korotkogo massiva: " << srednee(X, 0, N - 1) << endl;
else
{
int delta = max - min;
for(int i = max; i < N; i++)
X[i - delta + 1] = X[i];
cout << "srednee znachenie korotkogo massiva: " << srednee(X, 0, N - delta) << endl;
system("pause");
return 0;
}
}

СРОЧНО!!! Нужно точное решение!!!

определить какое значение имеет true или false?
(-3>=5) or not(7>0) and (0<=3)
при вычислении соблюдать следующий приоритет выполнения операции.
1) выражение заключённые в скобки
2) логическое отрицание
3) логическое умножение
4) логическое сложение, исключающее или
5) операции отношения

Читайте также

Помогите написать программу в паскале!Очень надо!

Задана последовательность целых чисел,количество которых не превосходит 100.Требуется определить за один проход элемент с максимальным значением,а также число его повторений в последовательности.

Помогите пожалуйста с задачей по информатике!Без массива!Напишите в паскале!Очень надо!!

Опишите этапы решения на компьютере задачи нахождения значения a^b для целых чисел 0<a,b<10.

Помогите пожалуйста, очень надо :( "Расследование на диване" (по изображению - во влажениях) Итак, представьте: Вы

следователь-детектив. Наконец то вы ушли в отпуск и вы лежите на диване, читая книжку. Неожиданно раздался звонок в дверь. На пороге стояла взволнованная соседка. Оказалось, что она недавно нашла рисунок, на котором узнала своего сына. У сына есть друг Саша, который хорошо рисует, и она предполагает, что он нарисовал их отдых. Но женщина ничего не знала об этом событии, и очень просила вас помочь ей узнать как было дело. Взглянув на изображение (изображение во влажениях) вы смогли ответить на все ее вопросы:

1 . В какой день (число и месяц) начался этот отдых в лесу? 2. Сколько человек вместе с сыном жили в этом лагере? 3. На чем они приехали? 4. Какого числа был сделан рисунок? 5. В какое время суток был сделан рисунок? 6. Далеко ли от лагеря до ближайшего селения? 7. С какой стороны света дул ветер?

очень надо пожалуйста помогите завтра сдавать а я вообще не понимаю.

5.Укажите, какие из указанных ниже операций допустимы в Паскале:
var a1,a2:string; b1,b2:string[80]; c:string[5];
1) a1=a2;
2) b2>b1;
3) a1<=b2;
4) c=b1;
5) c:=a2;
6) a2:='b1+b2';
7) a1:=a2;
8) a2:=b2;
9) c>='12345';
10) a1<>'**';
11) c:=a1+b2.
6.Укажите, какие из указанных ниже выражений допустимы в Паскале:

Var a1, a2 : string; b1,b2 : string[80];

C : string[5];

1) copy(a1,5,3) + length(a2); 2) length(b2) + pos(‘aa’,b1);

3) pos(c,a1) + length(copy(c,6,2)); 4) b1 + copy(b2,65,20);

5) insert(copy(c,2,3), a2+b2,3); 6) delete(copy(a2,5,6),3,4);

7) insert(copy(a1,5,5),a2,3); 8) insert(a1,a2,length(a2)).
7.1) 1) concat('кро',a,b) при a='код', b='ил';
2) copy(s,2,3) при s='крокодил';
3) copy(s,4,2)+s[2]+s[7]+s[6]+s[5]+s[2] при s='крокодил';
4) pos('око',s) при s='крокодил';
5) pos('я','крокодил');
6) pos('а','ёеуыаоэяию');
7) pos('б','ёеуыаоэяию');
8) length('зеленый'+' '+s) при s='крокодил';
9) insert('чо',w,5) при w='моряк';
10) insert('Н',d,3) при d='око';
11) delete(w,5,2) при w='морячок';
12) str(123,s);
13) pos('а','аяоёуюыиэе')>0;
14) pos('б','аяоёуюыиэеАЯОЁУЮЫИЭЕ')>0;concat('кро',a,b)
copy(s,4,2)+s[2]+s[7]+s[6]+s[5]+s[2]



Вы находитесь на странице вопроса "как нарисовать слона в паскале. очень надо!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.