Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано натуральное число. Найти минимальную цифру.

5-9 класс

Yura0997230162 18 апр. 2015 г., 14:37:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sevikto
18 апр. 2015 г., 16:08:37 (9 лет назад)

 

program xxx;
  var a, b, min :integer;
begin
  write('введите число а='); 

  readln(a);

  min:=10;
  while a <> 0 do
    begin
       b:= a mod 10;
       if b < min then min:=b;
       a:= a div 10
    end;
  writeln('минимальная цифра = ', min);
  readln
end.

+ 0 -
Minmark98
18 апр. 2015 г., 17:00:00 (9 лет назад)

program dddd;
uses crt;
var a,b,c,i:integer;
begin
clrscr;
c:=10;
readln(a);
while a <> 0 do
begin
b:= a mod 10;
if b < c then c:=b;
a:= a div 10;
end;
writeln(c);
readkey;
end.

Ответить

Другие вопросы из категории

Пожалуйста помогите:)

Внимательно рассмотрите числа, расположенные в каждом из рядов и определите, какое число является "лишним". Зачеркините это число.

1)18,12,3,29,45,28
2)24,29,22,37,25,28

3)1,2,4,5,6,7

ПРОЦЕСС СВЯЗАННЫЙ С ИЗМЕРЕНИЕМ ИНФОРМАЦИИ ИЛИ ДЕЙСТВИЯМИ С ИСПОЛЬЗОВАНИЕМ ИНФОРМАЦИИ ВАРИАНТЫ ОТВЕТА:1)ПОЛУЧЕНИЯ ИНФОРМАЦИИ 2)ОБРОБОТКА ИНФОРМАЦИИ

3)ИНФОРМАЦИОННЫЙ ОБЪЕКТ 4)ИНФОРМАЦИОННЫЙ ПРОЦЕСС 5) ИНФОРМАЦИОННАЯ ДЕЯТЕЛЬНОСТЬ ПОМОГИТЕ ПОЖАЛУЙСТА

Сколько времени потребуется для ввода в память компьютера текста рома Дюма "Три мушкетера" с помощью сканера и программы для распознавания текста,если

известно ,что на сканирование одной страницы уходит 3 с, на смену страницы в сканере - 2 с, на распознавания страницы 3 с ?

Читайте также

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).

НАПИСАТЬ ПРОГРАММЫ(ПАСКАЛЬ)

Дано натуральное число.Определить номер цифры 8 в нем,считая от конца числа ,Если такой цифры нет,ответом должно быть число 0,если таких цифр в числе несколько -должен быть определен номер самой левой из них

Дано натуральное число.определить,сколько раз в нем встречается минимальная цифра (например для числа 102200 ответ равен 3,для числа 30330-2)

Найти 10 первых натуральных чисел ,оканчивающихся на цифру 7 кратных числу 9 и находящихся в интервале ,левая граница которго равно 100

задача 1. Дано натуральное число n. Напишите программу выводящую на экран последовательность натуральных чисел от 1 до n. задача 2. Даны

натуральные числа A , B, где B>A. Напишите программу последовательность натуральных чисел от A до B, включающая A и B.

Пожалуйста помогите !!!!!!!!



Вы находитесь на странице вопроса "Дано натуральное число. Найти минимальную цифру.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.