Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогитее решить на Turbo Pascal,пожалуйстаа

10-11 класс

Дан
массив целых чисел, состоящий из 10 элементов. Заполнить его с клавиатуры.
Найти:


сумму элементов, имеющих нечетное
значение;

БусинкаЯна 31 окт. 2013 г., 10:23:33 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Masha1717
31 окт. 2013 г., 12:56:52 (10 лет назад)

const  n = 10;
var  mas :array [1..n] of integer;  i, sum, a, k, sch :integer;
begin
  writeln('Введите массив:');  for i:= 1 to n do    readln(mas[i]);  writeln('Введите число A:');  readln(a);  writeln('Введите число k:');  readln(k);    sum:= 0;  for i:= 1 to n do    if mas[i] mod 2 = 1 then      sum:= sum + mas[i];  writeln('Сумма элементов равна ',sum);    writeln('Индексы, значение элементов которых больше ',a,' :');  for i:= 1 to n do    if mas[i] > a then      write(i,' ');  writeln;    sch:= 0;  for i:= 1 to n do    if mas[i] mod k = 0 then      sch:= 1;  if sch = 1 then    writeln('В массиве есть элементы, кратные ',k)  else    writeln('В массиве нет элементов, кратных ',k);    for i:= 1 to n do    if mas[i] mod 5 = 0 then    begin      mas[i]:= 0;      break;    end;
end.

Ответить

Другие вопросы из категории

Для чого служить оператор WRITELN
Пожаааалуйста, помогите(только не из интернета брать, там не правильно).

Даны две точки А(х1,у1) и В(х2,у2). Составить алгоритм, определяющий, которая из точек находится ближе к точке (2,5).(Паскаль).

Дан двумерный массив целых числе i=10 j=15, Заполняется случайным образом целыми числами от 0до 100. 1) Определить сколько раз в нем встречается

элемент со значеием х. х задается прользователем

2) Определить количесво четных элементов массива.

Читайте также

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

Написать программу на turbo pascal.

1.Вычислить значение факториала n! (P=1*2*...*n*N)..N=12
2.Найти сумму элементов заданного массива C[1..n]. Данные для ввода: n=7; C[1;2;3;-4;5;-6;7].
3.

Вводится последовательность целых чисел, по абсолютной величине меньших или равных 100.Найти и вывести на печать максимальный элемент и число

отрицательных элементов, расположенных после первого нулевого элемента.
Кто может плз очень срочно решить,желательно без массивов,но если не выйдет то через них.На языке Turbo Pascal



Вы находитесь на странице вопроса "Помогитее решить на Turbo Pascal,пожалуйстаа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.