Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1Каждый солнечный день улитка, сидящая на дереве, поднимается вверх на 2 см, а каждый пасмурный день опускается вниз на 1 см, В начале наблюдения

10-11 класс

улитка находится в A см от земли на B-метровом дереве. Имеется 30-элементный массив, содержащий сведения о том, был ли соответствующий день наблюдения пасмурным или солнечным. Написать программу, определяющую местоположение улитки к концу 30-го дня наблюдения.
2.

Jane12233445 03 марта 2015 г., 11:06:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Жибуля
03 марта 2015 г., 12:18:54 (9 лет назад)

Program Ulitka;
Var SunnyDay: Array [1..30] Of Boolean;
a, b, c, i: Integer;
Begin
WriteLn('a = ');
ReadLn(a);
WriteLn('b = ');
ReadLn(b);
b := b * 100;
Randomize;
For i := 1 To 30 Do
Begin      
If Random(2) = 1 Then
SunnyDay[i] := True
Else
SunnyDay[i] := False;
End;
For i := 1 To 30 Do
Begin  
If SunnyDay[i] = True Then
Begin    
a := a + 2;    
If a > b Then    
a := b;  
End  
Else  
Begin   
a := a - 1;    
If a < 0 Then    
a := 0;  
End;  
End;
WriteLn('Дни месяца были таковы:');
For i := 1 To 30 Do Begin
If SunnyDay[i] = True Then
WriteLn(i, '. Солнечный')
Else
WriteLn(i, '. Пасмурный')
End;
WriteLn('К концу 30 дня местоположение улитки равно ', a, ' см над землей');
ReadLn;
End.

Ответить

Другие вопросы из категории

Подберите окончание для предложения. Графический редактор - это ... . а)устройство для создания и редактирования рисунков б) программа

для создания и редактирования текстовых документов

в) устройство для печати рисунков на бумаге

г) программа для создания и редактирования рисунков

Читайте также

каждый солнечный день улитка сидящая на дереве поднимается вверх на 2 см а в пасмурный день опускается на 10 см. в начале недели улитка находилась на а см

от земли и на в метровом дереве. Имеются 30 массив, содержащий сведения о том был ли соответствующий день пасмурным. Определить место положения улитки к концу 30 дня. паскаль

каждый солнечный день улитка сидящая на дереве поднимается на 2см а в каждый пасмурный день опускается на 1см . в начале ноября улитка находилась ы А см

от земли на В дереве .имеется 30 элем.массив содержащим сведенья о том был ли соответствующий деньпасмурным или солнечным . написать программу определяющее место положения улитки к концу 30 дня наблюдения

Пользователь работал с каталогом с:\компьютер\Память. сначало он спустился в каталог ВИНЧЕСТЕР после этого поднялся на один уревень вверх затем еще раз под

нялся на один уровень вверх и даллее спустился в каталог ПРОЦЕССОРЫ укажите полный ответ который оказался пользователь
1-с:\компьютеры\Память\винчестеры
2-с:\компьютеры\Память\процессор ы
3-с:\винчестеры\процессоры
3-с:\компьютеры\процессоры

Улитка ползёт по вертикальному шесту высотой h метров, поднимаясь за день на a метров, а за ночь спускаясь на b метров. На какой день улитка доползёт

до вершины шеста? Программа получает на вход натуральные числа h, a, b и должна вывести одно натуральное число. Гарантируется, что a>b. При решении этой задачи нельзя пользоваться условной инструкцией if и циклами. Примеры Входные данные 10 3 2 Выходные данные 8

Катя, Наташа, Римма и Лиля – студентки факультета иностранных языков – увлекаются музыкой и каждая из них играет на каком-нибудь инструменте, но только на

одном: гитаре, скрипке, арфе или фортепиано.

Каждая из них учится на одном из отделений факультета: английского, французского, немецкого или испанского языка.

Та из них, которая играет на гитаре, учится на отделении испанского языка. Наташа не играет ни на скрипке, ни на арфе, и не учится на отделении английского языка. Катя тоже не играет ни на арфе, ни на скрипке и не учится на отделении английского языка. Студентка отделения немецкого языка не играет на арфе. А Римма учится на отделении французского языка и не играет на скрипке.

На каком инструменте играет и на каком отделении факультета иностранных языков учится каждая из студенток?

получается лилия играет на скрипке и не играется на гитаре, не учится на французском.

рима на французском но не играет на скрипке

наташа не на англйским и не играет не на скрипке не на арфе

катя не на английском не на скрипке не на арфе



Вы находитесь на странице вопроса "1Каждый солнечный день улитка, сидящая на дереве, поднимается вверх на 2 см, а каждый пасмурный день опускается вниз на 1 см, В начале наблюдения", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.