Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

каждый солнечный день улитка сидящая на дереве поднимается на 2см а в каждый пасмурный день опускается на 1см . в начале ноября улитка находилась ы А см

10-11 класс

от земли на В дереве .имеется 30 элем.массив содержащим сведенья о том был ли соответствующий деньпасмурным или солнечным . написать программу определяющее место положения улитки к концу 30 дня наблюдения

даня1000 10 мая 2013 г., 6:50:24 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ranis98
10 мая 2013 г., 9:29:16 (10 лет назад)

Program Ulitka;
Var SunnyDay: Array [1..30] Of Boolean;
a, b, c, i: Integer;
Begin
WriteLn('a = ');
ReadLn(a);
WriteLn('b = ');
ReadLn(b);
b := b * 100;
Randomize;
For i := 1 To 30 Do
Begin      
If Random(2) = 1 Then
SunnyDay[i] := True
Else
SunnyDay[i] := False;
End;
For i := 1 To 30 Do
Begin  
If SunnyDay[i] = True Then
Begin    
a := a + 2;    
If a > b Then    
a := b;  
End  
Else  
Begin   
a := a - 1;    
If a < 0 Then    
a := 0;  
End;  
End;
WriteLn('Дни месяца были таковы:');
For i := 1 To 30 Do Begin
If SunnyDay[i] = True Then
WriteLn(i, '. Солнечный')
Else
WriteLn(i, '. Пасмурный')
End;
WriteLn('К концу 30 дня местоположение улитки равно ', a, ' см над землей');
ReadLn;
End.

Ответить

Другие вопросы из категории

Пожалуйста помогите) Для чего предназначены программные продукты (ПП)? Что понимают под образовательными информационными ресурсами?

Перевести десятичные числа в двоичную,восьмеричную и 16-ричную.системы счисления:

а)число 247_10(внизу)=?_2(внизу)

б)число 247_10=?_16

с)число 247_10_=?_8

г)число 557_10=?_2

д)число557_10=?_16

е)число 557_10=?_8

Читайте также

каждый солнечный день улитка сидящая на дереве поднимается вверх на 2 см а в пасмурный день опускается на 10 см. в начале недели улитка находилась на а см

от земли и на в метровом дереве. Имеются 30 массив, содержащий сведения о том был ли соответствующий день пасмурным. Определить место положения улитки к концу 30 дня. паскаль

1Каждый солнечный день улитка, сидящая на дереве, поднимается вверх на 2 см, а каждый пасмурный день опускается вниз на 1 см, В начале наблюдения

улитка находится в A см от земли на B-метровом дереве. Имеется 30-элементный массив, содержащий сведения о том, был ли соответствующий день наблюдения пасмурным или солнечным. Написать программу, определяющую местоположение улитки к концу 30-го дня наблюдения.
2.

Улитка ползёт по вертикальному шесту высотой h метров, поднимаясь за день на a метров, а за ночь спускаясь на b метров. На какой день улитка доползёт

до вершины шеста? Программа получает на вход натуральные числа h, a, b и должна вывести одно натуральное число. Гарантируется, что a>b. При решении этой задачи нельзя пользоваться условной инструкцией if и циклами. Примеры Входные данные 10 3 2 Выходные данные 8

Спортсмен, начав тренировки, в первый день пробежал 10 км. Каждый следующий день он увеличивал дистанцию на 12 %. Написать программу, определяющую общую

длину пробега за месяц и первый день с начала тренировок, после которого дистанция превысит 25 км.
паскаль!!!

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3



Вы находитесь на странице вопроса "каждый солнечный день улитка сидящая на дереве поднимается на 2см а в каждый пасмурный день опускается на 1см . в начале ноября улитка находилась ы А см", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.