Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

СРОЧНО Составить блок схему и программу для вычисления значения функции y в зависимости от х

10-11 класс

Про100Аню 23 дек. 2014 г., 2:28:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
6565zhanodoc
23 дек. 2014 г., 5:16:56 (9 лет назад)

var
  x, y: real;

begin
  Write('Введите значение аргумента: ');
  Readln(x);
  if x <= 1 then y := -1 / sqr(x)
  else if x <= 0 then y := -x
  else y := -sqr(x);
  Writeln('Значение функции равно ', y)
end.

Тестовое решение:

Введите значение аргумента: -2.7
Значение функции равно -0.137174211248285


+ 0 -
Dema01
23 дек. 2014 г., 7:32:29 (9 лет назад)

Вот так вот получилось. Записать можно каждый прямоугольник под ромбом 

Ответить

Другие вопросы из категории

Помогите, пожалуйста!!!

К визуальной компоненте для выбора значений относится:


1. Label

2. Shape

3. SpinEdit

4. Image

5. ListBox

привести примеры ситуации в которых информация: 1- создается. 2-. обрабатывается в. запоминается 3-. делится на части. 4-. копируется. 5-.

воспринимается 6-. измеряется. 7. принимается 8-. передается. 9-разрушается 10-передается

Читайте также

Помогите составить программу для вычисления значения функции y для заданного значения x

у= если x<-3 то
y= √1 - x²
если 1,5<x-3, то
y= в числителе 1 в знаменателе модуль x +2
если x>1,5, то
y=tg x
Составить словесное описание алгоритма, составить блок схему, описать используемые элементы

Написать программу на языке Паскаль для вычисления значений функции y (см. для своего варианта) на интервале [a,b] с шагом h. Значения a,b и h ввести с

клавиатуры. На экран вывести результат вычислений в виде таблицы. 1 Блок-схема алгоритма программы, выполненная с использованием графических средств редактора WORD; 2 Текст программы; 3 Результаты выполнения (копия экрана). (3x+2)^2- sqrt3x/(3x)^2 a 5;b 7; h 0,1



Вы находитесь на странице вопроса "СРОЧНО Составить блок схему и программу для вычисления значения функции y в зависимости от х", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.