Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составить программу нахождения наибольшего числа из введенных с клавиатуры. В Паскале с помощью цикла.

5-9 класс

0909Элина1999 08 апр. 2014 г., 10:07:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gogen13Pehota
08 апр. 2014 г., 11:45:40 (10 лет назад)

var max,n,c,i:integer;
begin
readln(n); //сколько чисел будет всего введено
readln(c);
max:=c;
for i:=1 to n-1 do begin
   readln(c);
   if max<c then max:=c;
   end;
writeln(max);
end.
//это один из самых производительных алгоритмов, без лишних записей в массив и траты памяти

Ответить

Другие вопросы из категории

Некоторое натуральное число, записанное в системе счисления с основанием x, является трехзначным: abcx. В конец этого числа дописали его цифры в том же пор

ядке. Получилось шестизначное число abcabcx. Оказалось, что новое число в 4097 раз больше исходного. Определите основание системы счисления x. В ответе укажите целое число.

ПОМОГИТЕ ПОЖАЛУЙСТАА

ВСЁ ВО ВЛАЖЕНИИ
Благодарю заранее

Читайте также

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

Очень срочно, и очень нужно составить программы по информатике PASCAL ABC, помогите, пожалуйста от этих программ зависит моя четвертная.

1. Составьте программу для определения большего из двух чисел х или у
2. Составьте программу для нахождения площади прямоугольника по заданным сторонам а и б

ЯЗЫК QBASIC !!! Решите задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности

положительных чисел, которые вводятся с клавиатуры. 2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).



Вы находитесь на странице вопроса "Составить программу нахождения наибольшего числа из введенных с клавиатуры. В Паскале с помощью цикла.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.