Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три.

5-9 класс

Dan15 12 марта 2017 г., 10:44:41 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
092002
12 марта 2017 г., 13:00:21 (7 лет назад)

var
i,a,b:integer;
x: array[1..10] of integer;
begin
a:=0;
b:=0;
for i:=1 to 10 do
begin
begin
x[i]:=random(21)-10;
write(x[i]:4);
end;
if (x[i]>=0)and(x[i] mod 3=0) then
b:=b+1;
end;
writeln;
write('количество элементов положительных и кратных три = ',b);
writeln;
for i:=1 to 10 do
begin
a:=a+x[i];
end;
write('суммa = ',a);
end.

Ответить

Читайте также

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

НАПИШИТЕ ПОЖАЛУЙСТА ПРОГРАММУ ДЛЯ ПАСКАЛЯ: 1) Разработайте алгоритм для ввода в память ЭВМ линейной таблицы В, состоящей из 8 элементов вещественного

типа. Ввод организуйе без использования цикла 2) разработайте алгоритм для ввода в память ЭВМ одномерного массива С состоященр из 7 элементов целого тип. Ввод организуйе с исползованием цикла "ДЛЯ". 3) разработайте алгоритм для ввода в память ЭВМ одномерного массива Д состоящего из 10 элементов целого типа. Каждый элемнт вычислите по формуле: значение элемента равно квадрату его индекса

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.



Вы находитесь на странице вопроса "Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.