Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

найти сумму положительных нечетных чисел,меньших n. по паскалю

5-9 класс

Shirokovivan99 08 нояб. 2015 г., 10:56:00 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mydakov
08 нояб. 2015 г., 13:51:31 (8 лет назад)

uses crt; 
var i,s:integer; 
begin 
s:=0; 
for i:=1 to 100 do 
begin 
if ((i mod 2)=1) then s:=s+i; 
end; 
writeln('summa nechetnych chisel menshe sta ravna ',s); 
readkey;end.

+ 0 -
Kolyan985
08 нояб. 2015 г., 16:12:23 (8 лет назад)

а вдруг скажут сделать отрицатильные))

var i,s,n:integer;
begin
s:=0;
read(n);
for i:=-n to n do
begin
if (((i mod 2)=1)and (i > 0)) then s:=s+i;
end;
writeln('summa nechetnych chisel menshe sta ravna ',s);
readln;
end.

Ответить

Другие вопросы из категории

надо написать программу которая сравнивает два числа, введенных с клавиатуры. Программа должна указать, какое число больше или если числа равны вывести

соответствующие сообщение. Ниже представлен рекомендуемый вид экрана во время работы программы.Введите в одной строке два целых числа и нажмите <Enter>. ->34 67

Нужна помощь помогите задачи на переливание Однажды Вини-Пух захотел полакомится мёдом и пошел к пчелам в гости.По дороге нарвал букет цветов, подарить

труженицам пчелкам.Пчелки очень обрадовались,увидев мишку с букетом цветов, и сказали:У нас есть большая бочка с мёдом .Мы дадим тебе мёда,если ты сможешь с помощью двух сосудов вместимостью 3 л. и 5 л.. налить себе 4 л.Винни-Пух долго думал, но все-таки смог решить задачу.Как он это СДЕЛАЛ???

Читайте также

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

Программа для определения требуемых величин на побочной диагонали двумерного массива.

Размер 30
Имя D
Должна выполнять функции:
1)Найти минимальный элемент
2)Найти сумму положительных чисел
3)Минимальное четное число
4)Количество отрицательных четных чисел
5)Сумму положительных нечетных чисел

Дано натуральное число n.Найти сумму всех нечетных чисел от 1 до n

ПОМОГИТЕ ПОЖАЛУЙСТА! У МЕНЯ КОНТРОЛЬНАЯ!! ЗАРАНЕЕ БЛАГОДАРЮ!!)



Вы находитесь на странице вопроса "найти сумму положительных нечетных чисел,меньших n. по паскалю", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.