Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Элементы двумерного массива A(7,8) формируются датчиком случайных чисел из интервала [-20,70] . Организовать вывод на печать всего массива в виде

5-9 класс

таблицы,а также элементов массива,стоящих в четных столбцах.

Katrinl 05 нояб. 2016 г., 10:05:02 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Inna30061998
05 нояб. 2016 г., 11:51:42 (7 лет назад)

var
a: array [1..7, 1..8] of integer;
i, j: byte;
begin
Randomize;
writeln('***Массив***');
for i:=1 to 7 do 
begin 
for j:=1 to 8 do   
begin   
a[i,j]:= Random(91)-20;   
write(a[i, j]:5);   
end; 
writeln; 
end; 
writeln; 
writeln('***Элементы четных столбцов***'); 
j:=2; 
while j<=8 do   
begin   
write('Столбец ', j, ': ');   
for i:=1 to 7 do write(a[i, j]:5);   
j:=j+2;   
writeln;   
end;
end.

Ответить

Другие вопросы из категории

По каналу связи непрерывно в течение 10 часов передаются данные. Скорость передачи данных в течение первых 6 часов составляет 512 Кбит в секунду, а в

остальное время – в два раза меньше. Сколько Мбайт данные было передано за время работы канала?

Помогите

Составьте таблицу истинности
М или не С и не Р

Читайте также

сформулируйте массив,содержащий 15 элементов,с помощью датчика случайных чисел. получите новый массив,каждый элемент которого равен обратному

соответствующему элементу исходного массива. посчитайте кол- во неизменившихся эелементов и найдите в новом массиве максимальный о абсолютной величине отрицательный элемент. выведите на экран исходные и полученные результаты (ПОМОГИТЕ ПОЖЛСТ ОЧЕНЬ НАДО)

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. Получите новый массив, каждый элемент которого равен произведению

соответствующего элемента исходного массива и заданного с клавиатуры числа А. В проученном массиве найдите максимальный элемент среди элементов с нечетными номерами. Выведите на экран исходные полученные результаты.

1) составить программу , которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу , которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми
язык паскаль

Выполните следующие задания на обработку элементов двумерного массива:

Дан двумерный массив целых чисел (3 строки, 5 столбцов).
Заполните его с клавиатуры.поменяйте местами 1-й элемент 3-го столбца и 2-й элемент 3-й строки;



Вы находитесь на странице вопроса "Элементы двумерного массива A(7,8) формируются датчиком случайных чисел из интервала [-20,70] . Организовать вывод на печать всего массива в виде", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.