Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Выполните следующие задания на обработку элементов двумерного массива:

5-9 класс

Дан двумерный массив целых чисел (3 строки, 5 столбцов).
Заполните его с клавиатуры.поменяйте местами 1-й элемент 3-го столбца и 2-й элемент 3-й строки;

Zarina1995 21 авг. 2014 г., 20:33:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elizabetka02
21 авг. 2014 г., 22:24:09 (9 лет назад)

        static void Main()
        {
            int[,] arr = new int[3, 5];
            byte i = 0, j, nech = 0;
            while (i < 3)
            {
                j = 0;
                while (j < 5)
                {
                    Console.Write("arr[{0}, {1}] = ", i + 1, j + 1);
                    arr[i, j] = Int32.Parse(Console.ReadLine());
                    if (arr[i, j++]  2 == 1) nech++; //Сразу считаем нечётные элементы
                }
                Console.WriteLine();
                i++;
            }
            Console.WriteLine();
            for (i = 0; i < 3; i++) //Выводим массив
            {
                j = 0;
                while (j < 5)
                    Console.Write("{0,3}", arr[i, j++]);
                Console.WriteLine();
            }
            Console.WriteLine();
            int buf = arr[0, 2]; //Меняем местами
            arr[0, 2] = arr[2, 1];
            arr[2, 1] = buf;
            for (i = 0; i < 3; i++) //Выводим массив
            {
                j = 0;
                while (j < 5)
                    Console.Write("{0,3}", arr[i, j++]);
                Console.WriteLine();
            }
            long p = 1;
            for (j = 0; j < 5; j++)
                p *= arr[1, j];
            Console.WriteLine("Произведение эл. второй строк равно " + p);
            Console.WriteLine("Тут {0} несчётных элементов", nech);
            Console.ReadKey(false);
        }

+ 0 -
Gumpert
21 авг. 2014 г., 23:52:56 (9 лет назад)

Комментарий удален

+ 0 -
Vlada120804
22 авг. 2014 г., 2:48:06 (9 лет назад)

C#

+ 0 -
Vvolf
22 авг. 2014 г., 4:08:50 (9 лет назад)

Комментарий удален

+ 0 -
Superman111
22 авг. 2014 г., 6:29:08 (9 лет назад)

:D мне просто их слишком много задали 9 на if ,6 на case+ switch,и 3 на циклы,это все за 7 дней нужно сделать,))

+ 0 -
Давтян
22 авг. 2014 г., 8:03:48 (9 лет назад)

Комментарий удален

Ответить

Читайте также

Программа для определения требуемых величин на побочной диагонали двумерного массива.

Размер 30
Имя D
Должна выполнять функции:
1)Найти минимальный элемент
2)Найти сумму положительных чисел
3)Минимальное четное число
4)Количество отрицательных четных чисел
5)Сумму положительных нечетных чисел

1) составить программу , которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу , которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми
язык паскаль

1)составьте программу ввода элементов массива а[1..8 ] с клавиатуры и вывода на экран элементов с отрицательными значениями; 2)составьте

программу ввода элементов массива b[1..6] с клавиатуры и вывода на экран элементов с положительными значемиями

Помогите пожалуйста решить правильно и подробно 2 задачи по информатике: 1.Исправьте неточности в описании двумерного массива: Var

A= array[1..n,1..m] of integer;

2. Вставьте пропущенные определения:

… … двумерных массивов каждая строка заключается в дополнительную пару круглых скобок:

const a:mas= ((2,3,1,0),
(1,9,1,3),
(3,5,7,0));



Вы находитесь на странице вопроса "Выполните следующие задания на обработку элементов двумерного массива:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.