Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дано целое число А(А>2).определить является ли число чётным или нечётным (последовательно вычитаем из из числа А число 2 и определяем остаток)

5-9 класс

Alua20021 11 июля 2014 г., 13:34:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alialiaa
11 июля 2014 г., 16:05:40 (9 лет назад)

при деление на два остаток только 1 или 0, выполняем вычитание пока А больше 1

var A:integer;
Begin
writeln('Введите число А');
readln(A);
while A>1 do A:=A-2;
if A=0 then writeln('А - четное, остаток ',A)
else writeln('А - нечетное, остаток ',A)
End.

Ответить

Другие вопросы из категории

Задание 1

Сравните:
а)200байт и 0,25Кбайт
б)3байта и 24бита
в)1536бит и 1,5Кбайт
г)1000бит и 1Кбайт
Задание 2
Посчитайте в Кбайтах количество информации в тексте,если текст состоит из 800 символов, а мощность используемого алфавита=128символов.
Задание 3
Сколько символов в тексте, если мощность алфавита 64символа, а объем информации содержащийся в нем 1,5Кбайт.

Надо написать программу в паскале!

Дано число N. Напечатать нечетные натуральные числа меньше N.

Читайте также

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Ребят, помогите пожалуйста по Паскалю. 1. Написать программу, которая вводит последовательность вещественных чисел, состоящую

из N элементов, и определяет, является ли эта последовательность возрастающей.

2. Дан целочисленный массив размерности N. Необходимо "сжать" массив, выбросив из него каждый второй элемент. Дополнительный массив использовать нельзя.

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни



Вы находитесь на странице вопроса "Дано целое число А(А>2).определить является ли число чётным или нечётным (последовательно вычитаем из из числа А число 2 и определяем остаток)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.