Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Надо написать программу в паскале!

5-9 класс

Дано число N. Напечатать нечетные натуральные числа меньше N.

Pesegovilia 25 июня 2014 г., 12:04:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AJieXPuXT0H
25 июня 2014 г., 13:22:44 (9 лет назад)

const k=20;
var a:array [1..k] of integer;
i,n:integer;
begin
read(n);
for i:=1 to k do begin
a[i]:=random(k);
write(a[i]:4); - не обязательно, чисто, чтобы видеть какие числа сгенерировал рандом
end;
for i:=1 to k do
if (a[i] mod 2<>0) and (a[i]<n) then begin
writeln();
writeln();
write(a[i]:4);
end;
end.

+ 0 -
1danya11111
25 июня 2014 г., 14:01:56 (9 лет назад)

Program ch;
var a:integer;
Begin
writeln('Введите число n: ');
Readln(n);
For n:=n downto 1 do
writeln(n);
end.

+ 0 -
Lona2304
25 июня 2014 г., 15:39:26 (9 лет назад)

с 0?

+ 0 -
Smoujkeeee
25 июня 2014 г., 18:32:39 (9 лет назад)

Не знаю. Это весь текста задания. Хотя 0 не является натуральным числом, так что наверное нет.

Ответить

Другие вопросы из категории

Читайте также

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

Помогите пожалуйста! надо написать программу в паскале вот задание:

Заполнить массив К, состоящий из 22 элементов таким образом:



Вы находитесь на странице вопроса "Надо написать программу в паскале!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.