Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль:

10-11 класс

Найти сумму и количество всех трехзначных чисел, кратных 100

Vfhujif5530 16 мая 2014 г., 7:10:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hvhcyfyjbhb
16 мая 2014 г., 9:18:34 (10 лет назад)

var
 i,k,sum:Integer;
 Begin
  for i:=1 to 999 do
   begin
    if (i mod 100 =0) then
     begin
      Inc(k);
      sum:=sum+i;
     end;
  end;
  Writeln('Количество = ',k);
  Writeln('Сумма  = ',sum);
  end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПРОШУ.

Для целого числа k от 1 до 9 напечатать фразу «Мне k лет\года\год».
В делфи.

Помогите решить задачу в Кумире!

Пользователь вводит целое число. Каждую цифру в нем надо заменить по следующему принципу: "1" на "9", "2" на "8", "3" на "7" и т.д. Цифра "0" не меняется. Результат сохранить в отдельной переменной и вывести на экран. Например: ввод - "4569870", вывод - "6541230"

Помогите пожалуйста решить задание на Паскале по оператору перехода! Даны различные действительные числа a, b,

c, d.

Найти max (max(a, b), max(a, c), max(a, d)).Числа получить случайным
образом на интервале [-50..+50]

Помогите пожалуйста с инфоматикой. Написать программу на паскале.

Дан двумерный массив из пяти строк и пяти столбцов. Найти сумму элементов первой стоки и произведение элементов второго столбца.

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "Паскаль:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.