Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Паскаль. Оператор выбора.

5-9 класс

Дано натуральное число N (N<100), что означает возраст человека в годах. Дать для этого числа наименование: "год", "года", "лет".

Massmariya 07 авг. 2013 г., 16:18:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastyaneudakin
07 авг. 2013 г., 18:16:45 (10 лет назад)

var
  n:integer;
  s:string;
begin
readln(n);
case n mod 10 of
  1:s:=' год';
  2..4:s:=' года';
  0,5..9:s:=' лет';
  end;
case n mod 100 of  11..19:s:=' лет';
  end;
writeln(n,s);
end.

+ 0 -
HikkaLait
07 авг. 2013 г., 19:50:23 (10 лет назад)

Паскаль ABC:
Var
A:integer;
S:string;
Begin
ReadLn(A);
Case round(Power((A div 10) mod 10 -1,((A div 10) mod 10 -2)*((A div 10) mod 10 -3)*((A div 10) mod 10 -4)*((A div 10) mod 10 -5)*((A div 10) mod 10 -6)*((A div 10) mod 10 -7)*((A div 10) mod 10 -8)*((A div 10) mod 10 -9))*(A mod 10)) of
1:S:=' Год ';
2..4:S:=' Года ';
0,5..9:S:=' Лет ';
else S:='';
End;
WriteLn(A,S);
ReadLn
End.

Ответить

Другие вопросы из категории

Помогите, пожалуйста! Два игрока играют в следующую игру. Перед ними лежит куча из 6 камней. Игроки берут камни по очереди, за один ход можно

взять 1, 2 или 3 камня.Проигрывает тот, кто забирает последний камень. Кто выигрывает при безошибочной игре обоих игроков - игрок, делающий первый ход, или игрок, делающий второй ход? Каким должен быть первый ход выигрующего игрока? Ответ обоснуйте.

Помогите, срочно , очень срочно


Вы находитесь на странице вопроса "Паскаль. Оператор выбора.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.