Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

ребяяяят!!помогите пожаааалуйста!! Составить и записать на одном из языков программирования. с клавиатуры вводятся три числа А,В,С.Если А-чётное

10-11 класс

отрицательное,то вывести на экран значение суммы чисел А,В,С,иначе-значение произведения.

Ruslik16 23 дек. 2014 г., 0:37:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vladaalekseeva1
23 дек. 2014 г., 1:53:29 (9 лет назад)

{pascal}

var a,b,c:integer;

begin

readln(a,b,c);

if (a mod 2 = 0) and (a<0) then writeln(a+b+c) else writeln(a*b*c);

end.

 

//c++

#include <iostream>

using namespace std;

int main() {
int a,b,c;
cin>>a>>b>>c;
if (a%2==0 && a<0) {
cout<<(a+b+c);
}
else {
cout<<(a*b*c);
}
return 0;
}

Ответить

Другие вопросы из категории

___________А 10. ЕГЭ.
Расскажите мне про эту программу(Pascal), что к чему здесь(где процедуры, функции, циклы и т.п.). Совсем не дружу с программированием((

var f,g: Text;
s,s1: string;
p: integer;
begin
Assign(f,'names.txt');
assign(g,'out.txt');
Reset(f);
rewrite(g);
while not Eof(f) do begin
Readln(f,s);
while s<>'' do begin
p := pos(',',s);
if p>0 then begin s1 := copy(S,1,p-1); s := copy(S,p+1,length(S)) end
else begin s1 := s; s := '' end;
p := pos(' ',s1);
if p>0 then write(g,copy(S1,p+1,Length(S1)),' ',copy(S1,1,p-1));
if (S<>'')and(S[1]=' ') then Delete(S,1,1);
if S<>'' then write(g,', ');
end;
writeln(g);
end;
Close(f);
Close(g);
end.

Составить подпрограмму которая из матрицы F(k,m) K меньше либо равно 25,m меньше или равно 20 удаляет строку, содержащую минимальный элемент всей

матрицы. Глобальных переменных не использовать. В основной программе ввести исходные данные, с помощью подпрограммы получить результат и вывести матрицу до и после преобраз

срочно за деньги!!!

Читайте также

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать произвольные целые значения. С клавиатуры вводится целое число X. Опишите на

русском языке или на одном из языков программирования алгоритм, который находит и выводит наименьший номер элемента, равного X, или сообщение, что такого элемента нет.
const N=30;


var a: array [1..N] of integer;


i, j, x: integer;

Дан прямоугольный массив целых положительных чисел 10 х 20. Опишите на русском языке или на одном из языков программирования алгоритм поиска строки с

наименьшей суммой элементов. Вывести на печать номер строки и сумму ее элементов. Предполагается, что такая строка единственна.

помогите пожалуйста составить программу в Паскале!!

СРОЧНО!!! Дан целочисленный массив из 30 элементов, все элементы которого – неотрицательные числа, не превосходящие 10000. Опишите на русском

языке или на одном из языков программирования алгоритм, который находит и выводит минимальное трехзначное число, записанное в этом массиве. если таких чисел нет, нужно вывести сообщение «Таких чисел нет».

объяните решение пожалуйста программу не обязательно писать



Вы находитесь на странице вопроса "ребяяяят!!помогите пожаааалуйста!! Составить и записать на одном из языков программирования. с клавиатуры вводятся три числа А,В,С.Если А-чётное", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.