Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите оч срочно Паскаль 7 задание

5-9 класс

Dasha0Nalivayko 01 мая 2015 г., 4:33:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
LeXa1996
01 мая 2015 г., 7:15:56 (9 лет назад)

var
  x, y: integer;
  a, b: longint;

begin
  a := 1;  b := 1;
  readln(x);
  for y := 1 to 64 do
    if (y mod 2 = 1) then
      a *= x - y
    else
      b *= x - y;
  writeln(a / b);
end.

Только вот какая оказия: не смог я подобрать число, при котором возвращается "нормальное" значение... Но программа похожа на правильную

Ответить

Другие вопросы из категории

Решите пример. В ответе укажите получившееся число в нужной системе счисления

167(9)+544(8)=?(6) (цифры в скобках-это маленькие цифры снизу)

Митя,Серёжа,Толя,Юра и Костя пришли в музей до открытия и встали в очередь .Если бы Митя встал посередине очереди,то он стоял бы между Серёжей и Костей

,причём Костя стоял бы впереди Мити,а если бы Митя встал в конце очереди,то рядом с ним стоял бы Юра.Но Митя встал впереди своих товарищей .Кто за кем стоит?*

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПОМОГИТЕ ПОЖАЛУЙСТА СРОЧНО

Найдите произведение цифр заданного четырехзначного числа...Сделать программу на Паскаль

Помогите, пожалуйста, по Паскалю! 21. В компьютер вводятся два числа. Если первое больше второго, то вычислить их сумму, иначе - произведение.

После этого компьютер должен напечатать текст ЗАДАЧА РЕШЕНА.

22. В компьютер вводятся длины трех отрезков. Компьютер должен ответить на вопрос, правда ли, что пер-вый отрезок не слишком длинен, чтобы образовать с другими двумя отрезками треугольник. Указание: Для этого его длина должна быть меньше суммы длин двух других отрезков. Замечание: Пока не думайте о том, что слишком длинными могут быть второй или третий отрезки. Об этом – задание из 5.5.

ПОМОГИТЕ ПОЖАЛУЙСТА СРОЧНО!!!!!!!!!!!!!!!!!!!!!!!!

Помогите перевести из десятичной системы счисления в двоичную(10->2) числа: 17; 343
и из двоичной системы счисления в десятичную(2->10) число: 1101111012



Вы находитесь на странице вопроса "Помогите оч срочно Паскаль 7 задание", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.