Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите! Исправте ошибку. Условие было таким y:=√(1+4+9+...+36+49)

10-11 класс

Var x: integer, y: real
BEGIN
x := 1; y := 0;
while x <= 7 do
begin
y := y+sqrt(x*x);
x := x+1;
end;
y := sqrt(y);
writeln (y);
END.



Bestolkov 29 марта 2014 г., 19:13:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Acer2031
29 марта 2014 г., 20:20:55 (10 лет назад)

в начале X не обязательно присваивать 1
после begin должно быть
y:=y+sqr(x)

Ответить

Другие вопросы из категории

Какова максимально допустимая длина сегмента кабеля, определяемая в стандарте 10Base-2:

1) 100 метров

2) 185 метров

3) 300 метров

4) 1000 метров

5) 500 метров

Читайте также

Приветик, написала программу, помогите плиз сделать форматированный вывод, так чтобы все значения X были напсаныв первой строчке,значения sin во

второй, а tg на третьей строчки

program h;

var f:text;

x,y,z:real;

begin

assign (f,'c:\ty.txt');

reset (f);

rewrite(f);

x:=0;

while x<=3 do

begin

x:=x+0.1;

y:=sin(x);

z:=sin(x)/cos(x);

write(f,' x= ',x:4:2,' ');

write(f,'sin ',y:7:5, ' ');

write(f,'tg ',z:5:3,' ');

end;

close(f);

end.

Помогите, пожалуйста! Мне надо подробное решение.

На вход программе подается
последовательность символов, заканчивающаяся точкой. Требуется написать
программу, которая определяет, есть ли в этой последовательности десятичные
цифры, и выводит наибольшее число, которое можно составить из этих цифр.
Ведущих нулей в числе быть не должно (за исключением числа 0, запись которого
содержит ровно одну цифру). Если цифр нет, программа должна вывести на экран
слово «Нет», а если есть – слово «Да» и в следующей строчке искомое число.
Например, если исходная последовательность была такая:

Day 10, mice 8: "Year" 7 is a mistake 91.

помогите найти ошибку!
Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные,

отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных.

Листинг программы:

Program Massiv;

Const n=10;

Var A:array [1..4] of integer;

I, c, c2, c3: integer;

Begin

For i=1 to N do begin

Readln (a[i]); If (a[i]=0 then inc(c)

Else if ([ai]<0) then inc(c2)

Else inc (c3);

End;

Writeln (`нулевые:`,c);

Writeln (`отрицательные:`,c2);

Writeln (`положительные:`,c3);

End.

помогите ответить на вопросы))))1Что такое тег?

2Какие теги обуславливают начало HTML-программы?

3Какой тег обуславливает название Веб-страницы?



Вы находитесь на странице вопроса "Помогите! Исправте ошибку. Условие было таким y:=√(1+4+9+...+36+49)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.