Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Нарисовать круг, разделённый на N одинаковых частей, окрашенных в разный цвет. Количество частей N вводится с клавиатуры.

5-9 класс

Kamacool65 15 июня 2015 г., 3:38:27 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vita123lozko
15 июня 2015 г., 4:46:10 (8 лет назад)

uses GraphABC;
var n,i,a1,a2,r:integer;
begin
a1:=0;
write('Количество частей: ');
readln(n);
r:=round(360/n); 
for i:=1 to n do
  begin  a2:=a1+r;
  if i=n then a2:=360; 
  Brush.Color := clRandom;
  Pie(300,250,200,a1,a2);
  a1:=a2;
  end
end.

Если ввведено число, на которое 360 без остатка не делится, то один из секторов из-за округления получается больше, чем другие. Устранять это не стал, т.к. это привело бы к усложнению программы.

Ответить

Другие вопросы из категории

помогите с информатикой найдите лишнее слово

Клавиатура, джойстик, сканер, принтер.

Монитор, графопостроитель, принтер, мышь.


Жесткий диск, flash-память, компакт-диск, процессор.

Принтер, акустические колонки, наушники, микрофон.

Системный блок, центральный процессор, оперативная память, жесткий диск, блок питания.

Системный блок, клавиатура, мышь, монитор, акустические колонки.

Видеокарта, карта расширения, звуковая карта, сетевая карта.

Enter, End, Esc, Delete.

Цветной принтер, лазерный принтер, матричный принтер, струйный принтер.

Скажите какой ответ будет .Срочно !

Читайте также

Кто-нибудь кто хорошо разбирается в Pascal ABC,помогите,пожалуйста! 1.Нарисовать круг, разделённый на N одинаковых частей, окрашенных в разный цвет.

Количество частей N вводится с клавиатуры. 2.Нарисовать пирамиду из разноцветных прямоугольников.Количество прямоугольников вводится с клавиатуры. 3.С клавиатуры вводятся целые числа, пока не встретится ноль (ноль служит только для ограничения ввода и в дальнейших подсчётах не участвует) Вычислить произведение максимального и минимального числа. 4.С клавиатуры вводятся целые числа, пока не встретится ноль (ноль служит только для ограничения ввода и в дальнейших подсчётах не участвует). Известно, что среди первых двух чисел нуля нет. Найти сумму двух наибольших чисел. 5.С клавиатуры вводятся целые числа, пока не встретится ноль (ноль служит только для ограничения ввода и в дальнейших подсчётах не участвует). Известно, что среди первых трех чисел нуля нет. Найти среднее арифметическое трёх наименьших чисел.

Задача «Справедливое распределение»

У Андрея было А грамм крупы, у Бориса – В
грамм, а у Сергея вообще не было крупы.

Ребята сварили кашу и разделили ее поровну
на троих. Поскольку Сергей был без крупы, то

в благодарность за кашу он отдал С конфет
Андрею с Борисом.

Требуется написать программу, которая
определяет, как Андрей и Борис должны

поделить конфеты по справедливости.
Конфеты делить на части нельзя.

Описание входных данных

Входные данные вводятся с клавиатуры или
из файла input.txt. В единственной

строке записаны три целых числа А, В и С.

Описание выходных данных

Выходные данные выводятся на экран или в
файл output.txt. В единственной

строке необходимо вывести два целых числа
— количество конфет у Андрея и количество

конфет у Бориса.

Пример входных и выходных данных

Входные данные Выходные данные

700 500 12 9 3

Подробности от учителя:1.Определить значение переменной у после выполнения следующего фрагмента программы:

y:=1;
For i:=2 to 4 do y:=y+i;

2.Определить значение переменной у после выполнения следующего фрагмента программы:
y:=0;
For i:=-100 to 100 do
If i mod 10 =5 then y:=y+i;

3. На промежутке [a;b] (a,b -целые числа, которые вводятся с клавиатуры) определить среднее арифметическое чисел кратных 7

как распределить 8 литров подсолнечного масла на две равные части по 4 литра если кроме полного 8-литрового бидона есть два пустых бидона на 5 литров и на

3 литра.внизу указана схема в таком виде пожалуйста на пишите ответ только без таблицы.



Вы находитесь на странице вопроса "Нарисовать круг, разделённый на N одинаковых частей, окрашенных в разный цвет. Количество частей N вводится с клавиатуры.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.