Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1.) Дано трехзначное число. Определить, какая из его цифр больше: a. первая или вторая; b. вторая или последняя.

10-11 класс

Lizkaa111 21 марта 2014 г., 4:47:59 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Innak009
21 марта 2014 г., 6:25:22 (10 лет назад)

a)

Program Pr1;
uses crt;
var a,b,c:integer;
Begin
clrscr;
readln(a);
c:=a mod 10;
a:=a div 10;
b:=a mod 10;
a:=a div 10;
if a>b then writeln('Первая цифра >')
else writeln('Вторая цифра больше');
end.

b)

Program Pr1;
uses crt;
var a,b,c:integer;
Begin
clrscr;
readln(a);
c:=a mod 10;
a:=a div 10;
b:=a mod 10;
a:=a div 10;
if b>c then writeln('Вторая цифра >')
else writeln('Третья цифра больше');
end.

Ответить

Другие вопросы из категории

Написать программу VBA

вычисление S=2n+n!
да, там факториал, именно из-за него не могу составить программу. прошу помощи....спасибо за ранее огромнейшее!!!

Язык С++ Прога Dev++

Вычислить y=a*min(x,y,z)-b,где x,y,z,a,b-вводятся,причем a,b должны быть кратны 5,иначе выдать соответствующее сообщение
Вот как я написал
#include<iostream.h>
#include<conio.h>
#include<math.h>
int main()
{
int y,x,z,b,a;
cin>>x>>endl;
cin>>y>>endl;
cin>>z>>endl;
cin>>b>>endl;
cin>>a>>endl;
if ((a%5==0)&&(b%5==0))
if ((x<y)&&(y<z))
y=a*x-b cout<<y<<endl;
if ((y<x)&&(y<z))
y=a*y-b cout<<y<<endl;
if ((z<x)&&(x<q))
y=a*z-b cout<<y<<endl;
else cout<<"a,b ne kratnu 5";
getch();
return 0;
}

Читайте также

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1)Найти 3 совершенное число(программа+блок схемы)

2)Определить 35 простое число(программа +блок схемы)
3)Дано:трехзначное число ,определить :является ли произведение его цифр трехзначным числом(программа+блок схемы)

Автомат получает на вход два двузначных шестнадцатеричных числа . В этих числах все цифры не превосходят цифру 6 (если в числе есть цифра больше 6,

автомат отказывается работать). По этим числам строится новое шестнадцатеричное число по следующим правилам. 1) Вычисляются два шестнадцатеричных числа – сумма старших разрядов заданных чисел и сумма младших разрядов этих чисел . 2) Полученные два шестнадцатеричных числа записываются друг за другом в порядке возрастания (без разделителей). Пример. Исходные числа: 66, 43. Поразрядные суммы: A, 9. Результат: 9A. Определите, какое из предложенных чисел может быть результатом работы автомата : 1) AF 2) 410 3) 8B 4) 76 (и объясните, пожалуйста, как это решать вообще)) )

Дано натуральное число: определить а) количество цифр в нем б)сумму его цифр в)произведение его цифр г)среднее арифметическое его цифр

д)сумму квадратов его цифр е)сумму кубов его цифр ж)его первую цифру з)сумму его первой и последней цифр



Вы находитесь на странице вопроса "1.) Дано трехзначное число. Определить, какая из его цифр больше: a. первая или вторая; b. вторая или последняя.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.