Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Найти сумму пятнадцати нечетных чисел натурального ряда,

10-11 класс

начиная с N>0. N вводится с клавиатуры




Провидец 10 авг. 2016 г., 18:21:03 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Loised
10 авг. 2016 г., 20:24:35 (7 лет назад)

var
  i, n: byte;
  s: integer;
begin
  readln(n);
  for i := n to n + 15 * 2 - 1 do
    if (i mod 2 = 1) then
      s := s + i;
  writeln(s);
end.

+ 0 -
Софико123
10 авг. 2016 г., 21:03:05 (7 лет назад)

Возможно не самое лучшее решение, зато тут нет циклов и всего одна переменная :)
var n:integer;
begin
Writeln('Задайте N');
Readln(n);
if n mod 2 = 1 then 
n:=n+14*n+2*14;
else 
n:=n+1+14*n+2*14;
writeln('Сумма чисел:')
write(n);
readln;
end.

Ответить

Другие вопросы из категории

Собственно, надо сделать то, что написано на фотике, помогите, пожалуйста.

Все говорят, что легко, а я сделать не могу :(

Кто-нибудь может прямо построчно объяснить как это работает, и исправить код в случае ошибки?

function find(x:integer):boolean;
begin
if pos('7',IntToStr(x))=0
then result:=False
else result:=True
end;
const n = 1000;


var
a:array[1..n] of integer;
i:integer;i,o: file of text;

begin
AssignFile(i, 'Input.dat');
AssignFile(o, 'Output.dat');
Rewrite(o);
Reset(i);

for i:=1 to n do

дан массив, содержащий 70 неотрицательных целых чисел, не привышающих 1000. Опишите на одном из языков программирования алгоритм, позволяющий найти и вы

вести сумму двух соседних элементов массива, имеющих одинаковую чётность. Гарантируется, что в массиве есть соседние элементы, имеющие одинаковую чётность.

Читайте также

1) Задано положительное число A. Найти сумм всех четных чисел в интервале от 1 до A. Число А может иметь дробную часть.

2) Задано целое положительное число А и В. Найти квадратные корни целых чисел в интервале от А до В. Замечание: A<B

Найти сумму двузначных нечетных чисел. Вывести сумму. А также выводить на экран сколько вводилось двузначных чисел и сколько из них

было нечетных. То есть всего должно быть 3 вывода. Помогите пожалуйста!

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.



Вы находитесь на странице вопроса "Найти сумму пятнадцати нечетных чисел натурального ряда,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.