Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите составить программы в паскале по этим двум алгоритмам.

5-9 класс

Заранее спасибо!

45judo 11 окт. 2014 г., 5:34:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elenabelkva
11 окт. 2014 г., 8:21:00 (9 лет назад)

program n1;
 var (x,y);
begin
 read(x);
 if x<=-100 then y:=5x+10 else
  if (-100<x)and(x<=0) then y:=sqr(x)-1 else y:=abs(x);
 writeln('y=',y);
end.

program n2;
 var (x,y);
begin 
 raed(x);
 if x<=-20 then y:=3*sqr(x)*x else
  if (-20<x)and(x<=30) then y:=abs(x) else y:=30;
 writeln('y=',y);
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста !!!

а) Информация ,хранящаяся во внешней памяти и обозначенная именем ( 4 буквы ) .
б)Контейнер для файлов ( 5 букв ) .

1)Переведите в десятичную систему двоичное число 100001100 _{2} ;

2)Переведите в двоичную систему десятичное число 137 _{10} ;
3)Переведите в десятичную систему следующие числа
а) 151 _{8}
б)2С_{16}


Играют двое. Первый участник игры называет произвольное целое положи­тельное число, не превышающее десяти, то есть он может назвать число десять и всякое м

еньшее десяти положительное число. Второй игрок прибавляет к на­званному числу свое целое положительное число, также не превышающее десяти, и называет сумму. К этой сумме первый прибавляет какое-либо положительное число, не превышающее десяти, и сообщает сумму. Выигрывает тот, кто пер­вый достигнет ста.
Как добиться победы?

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Помогите составить программу по Паскалю, пожалуйста.

Клоун
предложил каждому из публики задумать число. Потом он сказал: «Прибавьте к
задуманному числу 5. Теперь из результата вычтите 2. А теперь к результату
прибавьте 7». Потом клоун спросил у желающих, какое число у каждого из них
получилось. Услышав ответ, он немедленно объявлял каждому, какое число тот
задумывал. Составьте программу, которая повторяла бы фокус клоуна.

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая: а)

определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на...



Вы находитесь на странице вопроса "Помогите составить программы в паскале по этим двум алгоритмам.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.