Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Почему не идет программа? в ответе нужны нечетные числа от 3 до 25

10-11 класс

program chislo;

var a,i:integer;

begin
i:=3;
writeln(i);

repeat
a:=i+2;
until a <56;
writeln(a);

end.

Dianaosmanova01 10 февр. 2014 г., 18:58:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elvixas
10 февр. 2014 г., 19:50:18 (10 лет назад)

var
   i: integer;

begin
  i := 3;
  writeln(i);
  repeat
     i := i + 2;
     writeln(i);
  until i >= 25;
end.

цикл этот работает, пока условие ложно) Да и переменная a лишняя, пожалуй)

Ответить

Другие вопросы из категории

Пожалуйста помогите!!!
WINDOWS основная директория хранения файлов операционной системы.Директория каталогов содержать следующие подкаталоги:system32 что содержит эта

папка?выбрать основные папки из нее
написать скрытые папки,в какой паки храняться драйверы

помогите написать конспект на эти темы

Читайте также

1)Написать программу вывода всех четных чисел от 2 до 1000 включительно

2)Написать программу определяющую сумму всех нечетных чисел от 1 до 99

Цикл for(Pascal)

решить задачку при помощи этого цикла:
напечатать все нечетные числа от 3 до 25

Запись

некоторого натурального числа X в шестнадцатеричной системе счисления имеет
ровно три значащих разряда. Это число увеличили в два раза, и оказалось, что
запись получившегося числа Y в шестнадцатеричной системе также имеет ровно три
значащих разряда, причем сумма цифр шестнадцатеричной записи исходного числа X
равна сумме цифр шестнадцатеричной записи полученного числа Y. Сколько
существует таких чисел X, которые удовлетворяют указанным условиям и при этом
содержат хотя бы одну цифру 2 в своей шестнадцатеричной записи? В ответе
укажите целое число.
Нужно составить программу, которая автоматически переберет все числа от 100 до FFF

Помогите плиииз=)

Привет. Помогите плиз=)
№1)Составить алгоритм вывода среднего(не арифметического) из трёх чисел в виде блок-схемы.
Входные данные:три числа
Выходные данные:среднее число

№2) На вход подаётся число. Нужно вывести числа от данного до 10. Если оно изначально больше 10, завершить программу.

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE



Вы находитесь на странице вопроса "Почему не идет программа? в ответе нужны нечетные числа от 3 до 25", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.