Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти предпоследнее составное число в диапазоне от 1 до n. написать код на языке С++

10-11 класс

Dasha030902 23 июля 2013 г., 21:57:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Уофна
24 июля 2013 г., 0:33:16 (10 лет назад)

#include <iostream>
using namespace std;

int del(int n)
{
  int c = 0;
  for (int i=2; i<=n/2; i++)
    if (n%i==0)
      ++c;
  return c;
}

int main()
{
  int n,a,k,tmp = 0,temp = 0,count = 0;
  do
  {
    cout <<"N = ";
    cin >> n;
  }
  while (n<1);
  for (int i=1; i<=n; i++)
  {
    cout <<"Chislo: ";
    cin >> a;
    if (del(a)!=0)
    {
     ++count;
     if (count==1)
       tmp = a;
     if (count==2)
     {
         k = tmp;
         temp = a;
     }  
     else if (count==3)
             {
               k = temp;
               count = 1;
               tmp = a;
             }
    }
  }
  cout <<"Sostavnoe chislo: " <<k <<endl;
  return 0;
}

+ 0 -
Damper1998
24 июля 2013 г., 1:31:36 (10 лет назад)

Работает с помощью решета эратосфена.
pastie.org/8430707

Ответить

Другие вопросы из категории

в магазине имеется 6 мониторов фирмы А, 7 мониторов фирмы В, 11 мониторов фирмы С и несколько мониторов фирмы D .Количество информации в сообщении "

куплен монитор фирмы D " равно 2 . Найдите количество мониторов фирмы D до покупки .
a) 1
b)2
c)8
d)16

каждый солнечный день улитка сидящая на дереве поднимается на 2см а в каждый пасмурный день опускается на 1см . в начале ноября улитка находилась ы А см

от земли на В дереве .имеется 30 элем.массив содержащим сведенья о том был ли соответствующий деньпасмурным или солнечным . написать программу определяющее место положения улитки к концу 30 дня наблюдения

Пожалуйста помогите) Для чего предназначены программные продукты (ПП)? Что понимают под образовательными информационными ресурсами?

Перевести десятичные числа в двоичную,восьмеричную и 16-ричную.системы счисления:

а)число 247_10(внизу)=?_2(внизу)

б)число 247_10=?_16

с)число 247_10_=?_8

г)число 557_10=?_2

д)число557_10=?_16

е)число 557_10=?_8

Читайте также

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE



Вы находитесь на странице вопроса "Найти предпоследнее составное число в диапазоне от 1 до n. написать код на языке С++", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.