Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны координаты двух противоположных вершин прямоугольника: (x1, y1), (x2, y2). Стороны прямоугольника параллельны осям координат. Найти периметр и

10-11 класс

площадь данного прямоугольника.

посик12 12 дек. 2014 г., 10:26:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MrNikitaMalkov
12 дек. 2014 г., 12:14:18 (9 лет назад)

program pryamougolnik;
var x1, x2, y1, y2, a, b, s, p:real;
begin
write ('Введите координату х1 = ');
readln (x1);
write ('Введите координату y1 = ');
readln (y1);
write ('Введите координату х2 = ');
readln (x2);
write ('Введите координату y2 = ');
readln (y2);
a:=abs(x2-x1);
b:=abs(y2-y1);
p:=(a+b)*2;
s:=a*b;
writeln ('Периметр прямоугольника P = ', p);
writeln ('Площадь прямоугольника S = ', s);
end.

+ 0 -
89039491181
12 дек. 2014 г., 13:15:45 (9 лет назад)

написать решение по паскалю.

Ответить

Другие вопросы из категории

1. В СОМ-технологии маршалинг используется для чего?

2. В СОМ-технологии информация место нахождении находится СОМ-сервера находится где?
3. Если приложение использует СОМ-сервер реализованный в виде DLL то это позволяет?
4. Если приложение использует СОМ-сервер реализованный в виде EXE то это позволяет?
5. В СОМ-технологии для облегчения корректного взаимодействия многопоточного клиента и однопоточного сервера используют?
ПОМОГИТЕ!

выполнить действия A-B , где A=121,B=59

Читайте также

3. Даны два неравных числа X и Y. Большее из них заменить на сумму этих чисел, а меньшее увеличить в три раза.

4. Известны периметр первого треугольника Р1, координаты вершин второго x1, y1, x2, y2,x3, y3 и длины сторон третьего – а3, в3, с3. Найти и вывести на экран периметр меньшего треугольника.

Алгоритмы ветвления

Помогите надо написать программу в паскале. 1)координаты двух различных полей шахматной доски x1, y1,x2, y2 (целые числа, лежащие в диапазоне 1–8).

Проверить истинность высказывания: «Ладья за один ход может перейти с одного поля на другое». 2) Дано трехзначное число. Проверить истинность высказывания: «Все цифры данного числа различны». 3)Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения. Вывести новые значения переменных A и B.

1)Стороны прямоугольника параллельны осям координат.Одна из вершин имеет координаты (0,0),координаты противоположной вершины задаются с

клавиатуры.Вычислите площадь прямоугольника. 2)С клавиатуры вводится натуральное число.Если оно кратно двум,напишите "четное число",иначе напишите "нечетное число".

написать программу на паскале Треугольник задан координатами (x1, y1), (x2, y2), (x3, y3)

своих вершин. Вычислить радиус окружности, вписанной в треугольник

Помогите составить программу, пожалуйста, нужно очень срочно! Пятиугольник ABCDE задан координатами своих вершин

(X1,Y1)(X2,Y2)(X3,Y3)(X4,Y4)(X5,Y5) соответственно. Найти площадь этого пятиугольника используя в качестве подпрограммы a) функцию



Вы находитесь на странице вопроса "Даны координаты двух противоположных вершин прямоугольника: (x1, y1), (x2, y2). Стороны прямоугольника параллельны осям координат. Найти периметр и", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.