Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Каким образом производится поиск документов по ключевым словам? В системе каталогов?

5-9 класс

IyaVokaloid 26 окт. 2014 г., 1:04:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MichelleCatlin
26 окт. 2014 г., 3:06:05 (9 лет назад)

свехру в программе есть книпка с изображением бинокля. Если ее нажать то, на экране откроется окно, в этом окне от вас требуется ввести слово которое вы хотите найти в документе и нажать "поиск". Когда программа найдет слово в документе, она выделит его цветом.

Ответить

Другие вопросы из категории

Вопрос №1: Текстовый редактор - программа, предназначенная для...

Выберите один из вариантов ответа:

Функции в Pascal!

Читайте также

СРОЧНО НАДО

1.Объясните, каким образом производится доставка данных по указанному Интернет-адресу?

Одной из задач, возникающей при разработке поисковых систем, является поиск самых популярных сайтов по ключевым словам (тегам), описывающим сайт. Дан

список сайтов. Про каждый сайт известны набор тегов сайта и его популярность. Есть запрос в виде набора тегов. На запрос необходимо выдать самый популярный сайт, у которого в описании встречаются все теги из запроса.
Формат входного файла

В первой строке входного файла input.txt находится набор тегов, разделённых ровно одним пробелом, количество тегов не превосходит 5. Тегом назовём такую строку, которая содержит только строчные латинские буквы и ее длина не превосходит 10 символов. В следующей строке дано число N (1 ≤ N ≤ 20)— количество сайтов.

Каждый сайт описывается тремя строками. В первой строке название сайта. Название сайта состоит только из строчных латинских букв и точки. Длина названия сайта не превосходит 15 символов. Во второй строке набор тегов сайта, разделенных пробелами. Количество тегов не превосходит 10. В третьей строке число Ai(1 ≤ Ai ≤ 1000000)— популярность сайта.
Формат выходного файла

В выходной файл output.txt требуется вывести любой самый популярный сайт, у которых встречаются все теги из запроса. Гарантируется, что найдётся, хотя бы один сайт отвечающий запросу.
Пример входных и выходных данных

Input.txt
football volleyball
5
sportbox.ru
sport football volleyball basketball swimming hockey
5000
championat.com
sport football volleyball basketball hockey
4000
soccer.ru
sport football
6000
sport.ru
sport football vоlleyball
1000
sports.ru
sport football volleyball basketball swimming hockey
2000

Output.txt

sportbox.ru

Я задачу решила, на мои тесты работает.

Однако, когда я отправляю ее тестировать на сайт, вылезает что программа выдала неправильный ответ.

program Project2;

{$APPTYPE CONSOLE}

uses
SysUtils;

var
s,r:string;
tegs,sait,d,x1:array[1..255] of string;
pop,l,x:array[1..100000] of integer;
i,j,k,n,f,max,max1:integer;
begin
assign(input,'Input.txt');reset(input);
assign(output,'Output.txt');rewrite(output);
readln(s);s:=s+' ';f:=0;
for i:= 1 to length(s) do begin
if s[i]<>' ' then r:=r+s[i];
if s[i]=' ' then begin k:=k+1;d[k]:=r;r:='';end;
end;
readln(n);
for i:= 1 to n do begin
readln(sait[i]);
readln(tegs[i]);
readln(pop[i]);
end;
for i:= 1 to n do begin
for j:= 1 to k do begin
if pos(d[j],tegs[i])<>0 then f:=f+1;
end;
l[i]:=f;
f:=0;
end;
max:=0;max1:=0;
f:=0;
for i:=1 to n do
if l[i]>max then max:=l[i];
for i:=1 to n do
if l[i]=max then begin inc(f);x[f]:=pop[i];x1[f]:=sait[i];end;
for i:=1 to f do
if x[i]>max1 then begin max:=x[i];k:=i;end;
writeln(x1[k]);
close(input);close(output);
end.

Поиск результатов по фразе "Для шифровки каждой буквы слова используется двузначное число. Известно, что буква " К" кодируется числом 15. Среди слов " Торт

", " ёжик", " станок", " Беседа" есть слова, кодируемые последовательностями цифр: 35291815, 303113241115. Какая последовательность цифр является кодом слова " Китенок""

Помогите, пожалуйста ! У меня Windows XP Professional Servis Pack 3 , после того как я переустановил Windows на эту же самую систему , начал вылетать

Интернет.
Вот загрузился рабочий стол, подключаю Интернет , захожу в браузер можно сделать поисковые запросы и через некоторое время тема на рабочем столе меняется на старую , помните она как бы такая белая , вся квадратная , ну вот ,а потом обратно на мою выбранную тему .При этом в сетевых подключения показывает , что Интернет подключен , локальная сеть тоже , а в браузере не могу производить поиск пишет : " Нет подключения к Интернету " После перезагрузки компьютера можно снова .
Кто знает помогите , пожалуйста !

Укажите, какой файл вы откроете, чтобыУкажите, какой файл вы откроете, чтобы прочесть инструкцию к игре.

Пятнашки.avi
Пятнашки.txt
Пятнашки.wav
Пятнашки.bmp
Пятнашки.com
Укажите, какой файл вы откроете чтобы прослушать музыкальное сопровождение к игре.
Пятнашки.avi
Пятнашки.txt
Пятнашки.wav
Пятнашки.bmp
Пятнашки.com
Укажите, какой файл вы откроете, чтобы прослушать музыкальное сопровождение к игре.
Пятнашки.avi
Пятнашки.txt
Пятнашки.wav
Пятнашки.bmp
Пятнашки.com
Укажите, с помощью какого файла вы запустите игру.
Пятнашки.avi
Пятнашки.txt
Пятнашки.wav
Пятнашки.bmp
Пятнашки.com
Укажите, как организованы следующие вложенные папки.
по принадлежности
по назначенибю
по содержимому
по времени создания
СРОЧНО НАДО!!



Вы находитесь на странице вопроса "Каким образом производится поиск документов по ключевым словам? В системе каталогов?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.