Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить программу по нахождению среднего арифметического всех чисел от 10 до 45. в паскале

10-11 класс

сашуня1 25 сент. 2014 г., 6:37:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anna82ov
25 сент. 2014 г., 8:13:11 (9 лет назад)

uses crt;
var i,average,count:integer;
begin
for i:=10 to 45 do
begin
average:=average+i;
inc(count);
end;
writeln(average/count);
end.

Ответить

Другие вопросы из категории

MICROSOFT EXCEL – ЭТО….:

1)средства ввода, поиска, размещения и выдачи больших массивов данных;
2)Программы для работы в компьютерной сети;
3)программы, позволяющие выполнять операции над данными, представленными в табличной форме;
4)средства проектирования электронных схем, машин, механизмов.

ПОМОГИТЕ СРОЧНОО

ПЛИЗЗ
ЗАСКРИньте как должно получится
а то я глубоко сомневаюсь что все так легко -_-

Требуется помощь в двух задачах, пишу сюда, ибо сам зашел в тупик. Желательно код с комментариями, дабы понять все:

1. Вывести на экран те строки файла, которые не содержат слово NO

Заранее спасибо

Плииззз...срочно надо..

частота вещания радиостанции равна 105.2 МГц. при настройке радиоприёмника на данную радиационную частота вещания составила 105.25 МГц.определите абсолютную и относительную погрешности, с которыми была установлена частота вещания. как скажутся последствия данной погрешности на работе радиоприёмника?

Сколько

различных решений имеет уравнение

Читайте также

помогите пожалуйста сделать=)))

а) Написать программу, определяющую среднее арифметическое всех чисел от 0 до заданного пользователем.

б)Написать программу, определяющую количество четных чисел от 0 до заданного пользователем числа.

Помогите исправить программу. Она должна вычислять среднее арифметическое всех чисел в массиве меньших 50. Вот программа:

Program Zadacha;
Uses crt;
var a:array[1..1000] of integer;
c,i,n,s :integer;
s1: real;
begin;
clrscr;
writeln("Введите размерность массива);
readln(n);
writeln('Введите массив');
for i:=1 to n do
begin a[i]:=random(100);
if a[i]<50 then begin inc(c); s:=s+a[i];end;s:=s+a[i];s1:=s/N;
writeln('Массив A:');
for i:=1 to N do write(a[i]:4);
writeln;
writeln('Среднее арифметическое равно=',s1);
end;
end.



Вы находитесь на странице вопроса "Составить программу по нахождению среднего арифметического всех чисел от 10 до 45. в паскале", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.