Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль помогите пожалуйста:(((( Каждый солнечный день улитка, сидящая на дереве, поднимается вверх на 2 см., а каждый пасмурный день опускается на

10-11 класс

1 см. В начале наблюдений улитка находится на А см. от земли на В-метровом дереве. Имеется 30-элементный массив, содержащий сведения о том, был ли соответствующий день наблюдения пасмурным или солнечным. Написать программу, определяющую местоположение улитки к концу 30-го дня наблюдений.

Arti1222 06 июня 2016 г., 18:48:47 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
LLIokep
06 июня 2016 г., 20:05:56 (7 лет назад)

uses crt;
const n=30;
var c: array[1..n] of integer;
a,b,i:integer;
begin
randomize;
writeln('на какой высоте была улитка');
readln(a);
writeln('ведите длину ветки');
readln(b);
for i:=1 to n do
begin
c[i]:=random(2)-0;{1-солнечно;0-пасмурно}
writeln(c[i]);
end;
writeln;
for i:=1 to n do
if (c[i]=0) then a:=a-1 else a:=a+2;
writeln(a,'см');
if a>b then writeln('улитка переползла ветку');
if a=b then writeln('улитка вернулась в начальное положение');
if a=0 then writeln('улитка спустилась до земли');
end.





+ 0 -
Stasaf93
06 июня 2016 г., 22:03:08 (7 лет назад)

Program Ulitka;
Var SunnyDay: Array [1..30] Of Boolean;
a, b, c, i: Integer;
Begin
WriteLn('a = ');
ReadLn(a);
WriteLn('b = ');
ReadLn(b);
b := b * 100;
Randomize;
For i := 1 To 30 Do
Begin
If Random(2) = 1 Then
SunnyDay[i] := True
Else SunnyDay[i] := False;
End;
For i := 1 To 30 Do Begin
If SunnyDay[i] = True Then
Begin
a := a + 2;
If a > b Then
a := b;
End
Else
Begin
a := a - 1;
If a < 0 Then
a := 0;
End;
End;
WriteLn('Дни месяца были таковы:');
For i := 1 To 30 Do Begin
If SunnyDay[i] = True Then
WriteLn(i, '. Солнечный')
Else
WriteLn(i, '. Пасмурный') End; WriteLn('К концу 30 дня местоположение улитки равно ', a, ' см над землей');
ReadLn;
End.

Ответить

Другие вопросы из категории

1. В каких случаях применяется оператор безусловного перехода goto: "перейти к"? 2. В каком

из условных операторов допущена синтаксическая ошибка?

3.

Cоставить алгоритм и программу для:

1)Заполнения лвумерного массива (6x4) произвольными значениями и вывода его на экран!
2)Подсчета произведения элементов по строкам и вывода на экран номеров строк и соответствующих произведений элементов!
3)Нахождения строки с максимальным произведением элементов и вывода на экран ее номера (номеров) и произведения элементов!
4) Выделения 1-го столбца в отдельный массив и сортировки его по возврастанию методом прямого выбора

Срочно необходима помощь. Требуется составить программу на VBA для решения систем линейных алгебраических уравнений , с помощью метода гаусса с выбором

главного элемента прямым и обратным ходом (матрицу в экселе вписываем самостоятельно, любой размерности ).Есть начало программы, но дальше нет мыслей...(

Читайте также

каждый солнечный день улитка сидящая на дереве поднимается вверх на 2 см а в пасмурный день опускается на 10 см. в начале недели улитка находилась на а см

от земли и на в метровом дереве. Имеются 30 массив, содержащий сведения о том был ли соответствующий день пасмурным. Определить место положения улитки к концу 30 дня. паскаль

1Каждый солнечный день улитка, сидящая на дереве, поднимается вверх на 2 см, а каждый пасмурный день опускается вниз на 1 см, В начале наблюдения

улитка находится в A см от земли на B-метровом дереве. Имеется 30-элементный массив, содержащий сведения о том, был ли соответствующий день наблюдения пасмурным или солнечным. Написать программу, определяющую местоположение улитки к концу 30-го дня наблюдения.
2.

каждый солнечный день улитка сидящая на дереве поднимается на 2см а в каждый пасмурный день опускается на 1см . в начале ноября улитка находилась ы А см

от земли на В дереве .имеется 30 элем.массив содержащим сведенья о том был ли соответствующий деньпасмурным или солнечным . написать программу определяющее место положения улитки к концу 30 дня наблюдения

Из 16-ти чисел, спросите у пользователя ,сколько нужно проанализировать чисел, а затем запросите эти числа и сделайте для каждого вывод, является ли

оно четным или отрицательным.(Паскаль)

Или так: Из 16 -ти чисел,сделайте для каждого вывод,является ли оно четным или отрицательным .(Паскаль)

Помогите пожалуйста,оченьььь срочно надо!Буду благодарна за решение ,спасибо!!!!!!!

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!



Вы находитесь на странице вопроса "Паскаль помогите пожалуйста:(((( Каждый солнечный день улитка, сидящая на дереве, поднимается вверх на 2 см., а каждый пасмурный день опускается на", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.