Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

напишите программы в abc паскале пожалуйста: 1)надо ввести три числа и найти из них наибольшее; 2)надо ввести пять чисел и найти из них наибольшее ЗАРАНЕЕ

10-11 класс

СПС!

Kasyanenko97 09 авг. 2016 г., 20:00:25 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Veneroooo
09 авг. 2016 г., 20:32:08 (7 лет назад)

program xcshiudcsk;

uses crt;

var a,b,c:integer;

begin

clrscr;

readln(a,b,c);

if (a>c) and (a>b) then writeln('max',a);

if (b>c) and (b>a) then writeln('max',b);

if (c>b) and (c>a) then writeln('max',c);

readln;

end.

 

 

Со второй все также, просто переменных побольше. Сделал таким образом, ибо на сложном условии запутаться можно.

Программа просит на ввод a.b.c 

Высчитывается наибольшее

Выводится наибольшее 

И через массив, конечно, можно, но про него ничего не сказано

 

+ 0 -
лера237502
09 авг. 2016 г., 21:22:22 (7 лет назад)

var a:array [1..100] of real;
i,n:integer;
max:real;
Begin
    writeln("Введите кол-во чисел");
    read(n);
    for i := 1 to n do
        read(a[i]);

    max:=a[1];
    for i:=2 to n do
        if max<a[i] then
           max:=a[i];
    write(max);
End.

Ответить

Другие вопросы из категории

Для каких целей необходимо системное ПО?

1) для разработки прикладного ПО 2)
для решения задач из проблемных областей

3) для управления ресурсами ЭВМ
4) для расширения возможностей ОС

Ребят, помогите пожалуйста, срочно.

ответ желательно на русском. Буду очень благодарна.

Световое табло состоит из цветных индикаторов. Каждый индикатор может окрашиваться в четыре цвета: белый, черный, желтый и красный. Какое

наименьшее количество лампочек должно находиться на табло, чтобы с его помощью можно было передать 300 различных сигналов?, пожалуйста решите мне быстрее

Паскаль помогите пожалуйста:(((( Каждый солнечный день улитка, сидящая на дереве, поднимается вверх на 2 см., а каждый пасмурный день опускается на

1 см. В начале наблюдений улитка находится на А см. от земли на В-метровом дереве. Имеется 30-элементный массив, содержащий сведения о том, был ли соответствующий день наблюдения пасмурным или солнечным. Написать программу, определяющую местоположение улитки к концу 30-го дня наблюдений.

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.

Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.



Вы находитесь на странице вопроса "напишите программы в abc паскале пожалуйста: 1)надо ввести три числа и найти из них наибольшее; 2)надо ввести пять чисел и найти из них наибольшее ЗАРАНЕЕ", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.